aspose file tools*
The moose likes Servlets and the fly likes Error - HTTP 404 - Status report Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Servlets
Bookmark "Error - HTTP 404 - Status report" Watch "Error - HTTP 404 - Status report" New topic
Author

Error - HTTP 404 - Status report

tangara goh
Ranch Hand

Joined: Dec 27, 2009
Posts: 125
Hi there,

I'm linking my validation form to a processMember.java under a default source package.

If all the required fields in the form are not filled up and user pressed submit, then it will ask them to fill up the fields.

But, when I press submit, it gives me this error :

type Status report

message /Practical4/processRegisterMember

description The requested resource (/Practical4/processRegisterMember) is not available.

Please help me.

Thanks.

Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61606
    
  67

Classes must be in a package other than the default.


[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
tangara goh
Ranch Hand

Joined: Dec 27, 2009
Posts: 125
Hi,

I have put it under a package name MemberManager under the sourcePackage directory. Still it's not working.

Further, the servlet is giving me the following error:-

There are no servlet mappings specified in web.xmls for ProcessRegisterMember servlet.

Please advise. My ProcessRegisterMember servlet is supposed to handle the data collected from the form registration and added the data into a table in Msaccess.

Please help me. Urgent. Tks.

Seetharaman Venkatasamy
Ranch Hand

Joined: Jan 28, 2008
Posts: 5575

tangara goh wrote:There are no servlet mappings specified in web.xmls for ProcessRegisterMember servlet.


so did you check this[url-pattern of your <servlet-mapping>]? [/Practical4/processRegisterMember]
tangara goh
Ranch Hand

Joined: Dec 27, 2009
Posts: 125
Here is how I add the xml:-

servlet-name>/Practical4/memberManager/processRegisterMember.java</servlet-name>
<url-pattern>/Practical4/memberManager/processRegisterMember.java</url-pattern>

It can be compiled now.

Howeve, when I run it, it gives me this error :-

Incrementally deploying http://localhost:8084/Practical4
Completed incremental distribution of http://localhost:8084/Practical4
Incrementally redeploying http://localhost:8084/Practical4
Start is in progress...
start?path=/Practical4
FAIL - Application at context path /Practical4 could not be started

C:\Documents and Settings\Desktop\Java Server Programming\Practical4\nbproject\build-impl.xml:577: The module has not been deployed.
BUILD FAILED (total time: 2 seconds)


Help! Please advise. Urgent.
veeresh soni
Greenhorn

Joined: Dec 10, 2009
Posts: 12
try by removing .java extension
tangara goh
Ranch Hand

Joined: Dec 27, 2009
Posts: 125
Removed already same problem, same error message.
Seetharaman Venkatasamy
Ranch Hand

Joined: Jan 28, 2008
Posts: 5575

please post your web.xml and how you are triggering the Servlet[Url]
tangara goh
Ranch Hand

Joined: Dec 27, 2009
Posts: 125
Please see attached. Hope that I have attached the right file. It does not allow me to copy the whole project file. Do you know how? So I just attached the web file.

Sorry I do not know how to do a screen shot.

I just posted but then this web site does not allow me to post up a xml file. Do you have an email address that I can send it to?

tangara goh
Ranch Hand

Joined: Dec 27, 2009
Posts: 125
Hi there,

I just sent the xml files to your email. Praying that you can help me. Tks.
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61606
    
  67

Please read this for more information.
tangara goh
Ranch Hand

Joined: Dec 27, 2009
Posts: 125
Hi,

I've just read your notice. Could you kindly make the attachments able to accept the xml files cause it can't and hence I had to resort to email.

Please advice.

tks.
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61606
    
  67

Post it using code tags.
tangara goh
Ranch Hand

Joined: Dec 27, 2009
Posts: 125
Netbean IDE does not allow me to copy and paste the wordings everything. Please read my last post - I have stated I could not do a screen shot which is the only way that I can show you guys the error.
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10263
    
168

tangara goh wrote:Netbean IDE does not allow me to copy and paste the wordings everything.


Open the web.xml in a text editor, copy the contents and paste here. Please remember to wrap it in a code block by using the Code button in the message editor window. And also please use the Preview button to ensure that your post is correctly formatted.


[My Blog] [JavaRanch Journal]
tangara goh
Ranch Hand

Joined: Dec 27, 2009
Posts: 125
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Error - HTTP 404 - Status report