aspose file tools*
The moose likes Other Java Products and Servers and the fly likes glassfishv3  admin exceptions Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Other Java Products and Servers
Bookmark "glassfishv3  admin exceptions " Watch "glassfishv3  admin exceptions " New topic
Author

glassfishv3 admin exceptions

Sherif Shehab
Ranch Hand

Joined: Mar 05, 2007
Posts: 483

Guys ,

i;m getting this exceptions when i;m trying to open the web admin for glassfish v3 , why i'm getting these exceptions ? the case is when i open the http://localhost:4848/login.jsf it keeps saying loading admin console the suddenly the page becomes white ..
here is my environment : windows 2000 advanced server SP4 , java 1.6.14


Thanks,
Sherif
K. Tsang
Bartender

Joined: Sep 13, 2007
Posts: 2359
    
    7

Glassfish v3 requies JDK 6u17. And you are using 6u14.


Required JDK Version
Installations require JDK 6. The minimum and certified version of the JDK software depends on the operating system:

•For supported operating systems exception MacOS, the minimum required version is 1.6.0_17.

•For MacOS, the minimum required version is 1.6.0_15.



K. Tsang JavaRanch SCJP5 SCJD/OCM-JD OCPJP7 OCPWCD5
Sherif Shehab
Ranch Hand

Joined: Mar 05, 2007
Posts: 483

OK i will upgrade to 1.6.17 then see what will happened .
Sherif Shehab
Ranch Hand

Joined: Mar 05, 2007
Posts: 483

Hi ,

Nothing changed after upgrading to jdk 1.6.17 , and i got these exception ..
Donald Jackson
Greenhorn

Joined: Mar 09, 2009
Posts: 19
I'm having the same problem. I'm using Winxp Pro with Netbeans 6.8 and I have my java system up to date with the current JDK and runtime. I can't seem to find a satisfactory answer. I'm trying to learn how to use the glassfish ap server and can't seem to get to first base with it. Can't even seem to get it started, let alone do anything with it.


Mark

Donald Jackson
Greenhorn

Joined: Mar 09, 2009
Posts: 19
OK.... good news folks. I got it going.

Now, here's a bit info that might be helpful to others who are new to messing with glassfish. For starters, I'm using the Netbeans 6.8 and the glassfish server that I've been trying to boot up is the server that comes with the netbeans jave ee download. I've been trying to boot it up using the right click context window that gives you the ability to start, stop, open the admin interface, etc.... This worked to start glassfish, but nothing else. I had upgraded my jdk and jre files to all the most recent versions as recommended in order to run glassfish version 3. Still no go. After a week of frustration I finally figured it out

Netbeans was using jdk 1.6.0_01 as it's default jdk even though I had installed a more recent jdk. I had to go into netbeans.conf file located in C:/Program Files/NetBeans 6.8/etc and change the ide's default jdk setting to jdk 1.6.0_17. Reboot....now it I am able to access the admin interface.

Hope this helps someone.

Mark

Sherif Shehab
Ranch Hand

Joined: Mar 05, 2007
Posts: 483

Donald Jackson wrote:OK.... good news folks. I got it going.

Now, here's a bit info that might be helpful to others who are new to messing with glassfish. For starters, I'm using the Netbeans 6.8 and the glassfish server that I've been trying to boot up is the server that comes with the netbeans jave ee download. I've been trying to boot it up using the right click context window that gives you the ability to start, stop, open the admin interface, etc.... This worked to start glassfish, but nothing else. I had upgraded my jdk and jre files to all the most recent versions as recommended in order to run glassfish version 3. Still no go. After a week of frustration I finally figured it out

Netbeans was using jdk 1.6.0_01 as it's default jdk even though I had installed a more recent jdk. I had to go into netbeans.conf file located in C:/Program Files/NetBeans 6.8/etc and change the ide's default jdk setting to jdk 1.6.0_17. Reboot....now it I am able to access the admin interface.

Hope this helps someone.

Mark



Donald you saved me with your idea ,

i was having a problem that i cant open the admin page for glassfish v3 , anyway i updated the jdk to the latest 1.6.0_17 and nothing happened so after a lot of investigation i figured that the glassfish still using the old jdk , so i found the Link that makes you to set the jdk that you wanna use inside the glassfish , and all working now fine Hope this may help anyone was facing my problem
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: glassfishv3 admin exceptions