File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes BEA/Weblogic and the fly likes jsp compilation failed Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "jsp compilation failed" Watch "jsp compilation failed" New topic
Author

jsp compilation failed

saipraneeth nallapareddy
Ranch Hand

Joined: Dec 02, 2009
Posts: 159
hi
i have the following tag included in my jsp file



this woks fine in my tomcat server but when it is uploaded to weblogic it is throwing an error


Compilation of JSP File XXXXXXXX failed
search.jsp:10:4: No tag library could be found with this URI. Possible causes could be that the URI is incorrect, or that there were errors during parsing of the .tld file.
<%@taglib uri="http://java.sun.com/jsp/jstl/core" prefix="core"%>



so how can i resolve this?
Travis Hein
Ranch Hand

Joined: Jun 06, 2006
Posts: 161
It's possible that tomcat has the java standard tag library (JSTL) bundled with it, in it's lib folder, so the web application deployed into tomcat just works. Where weblogic might not have the JSTL library, or possibly a different version and that URL is not finding it.

You can try to add the JSTL .jar files (such as jakarta standard tags http://tomcat.apache.org/taglibs/index.html) into your WEB-INF/lib inside the .war file, so that when this application is deployed into webspehere, it should just find these. This should also still allow it to work when deployed into a tomcat instance.


Error: Keyboard not attached. Press F1 to continue.
saipraneeth nallapareddy
Ranch Hand

Joined: Dec 02, 2009
Posts: 159
thank you for responding to the post
but i have rectified it earlier.
but any way thanks
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: jsp compilation failed
 
Similar Threads
jsp error
Error with JSTL tags in eclipse
jstl in tomcat 6.0
How to use JSTL?
JSTL problem