aspose file tools*
The moose likes Ant, Maven and Other Build Tools and the fly likes Maven issue - missing required library Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » Ant, Maven and Other Build Tools
Bookmark "Maven issue - missing required library" Watch "Maven issue - missing required library" New topic
Author

Maven issue - missing required library

Patricia Samuel
Ranch Hand

Joined: Sep 12, 2007
Posts: 300
While installing maven i was getting error of downloading a library. So i explicitly kept it into m2 folder.
But now in eclipse i am getting missing required library error.
I am not sure but i think i have to install this jar file explicitly. Please help me in resolving the error.
John Pradeep.v
Ranch Hand

Joined: Jul 21, 2008
Posts: 59
Patricia Samuel wrote:While installing maven i was getting error of downloading a library. So i explicitly kept it into m2 folder.
But now in eclipse i am getting missing required library error.
I am not sure but i think i have to install this jar file explicitly. Please help me in resolving the error.


Hi,
Can you please post the pom.xml and mention the JAR which is missing? also run mvn with '-e' option which will give a more verbose error which might help..

John
Patricia Samuel
Ranch Hand

Joined: Sep 12, 2007
Posts: 300
Thanks for the quick reply. its opensaml-1.0.1.jar. When i was installing the maven it was showing download error. so i copied jar to .m2 repository. Now in the eclipse under problem tab it says opensaml-1.0.jar is missing in .m2 repository and hence build path error.
John Pradeep.v
Ranch Hand

Joined: Jul 21, 2008
Posts: 59
Please post your pom.xml here... i would want to see the repository URL in specific.
Patricia Samuel
Ranch Hand

Joined: Sep 12, 2007
Posts: 300
it is resolved. Thanks a lot... i just updated the dependencies that should have been the first thing i need to be done.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Maven issue - missing required library