aspose file tools*
The moose likes JBoss/WildFly and the fly likes getting errors while running duke's bank application Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Reply locked New topic
Author

getting errors while running duke's bank application

beata jane
Ranch Hand

Joined: Sep 10, 2009
Posts: 43
Hi,
I am working with jboss4.0.2...
I tried to run duke's bank example according to the start guide4.0
I am getting the following errors..


D:\duke's bank\j2eetutorial14\examples\bank>ant -f jboss-build.xml db-create-tab
le
Buildfile: jboss-build.xml

db-create-table:
[java] update count 0

BUILD SUCCESSFUL
Total time: 0 seconds
D:\duke's bank\j2eetutorial14\examples\bank>ant -f jboss-build.xml db-insert
Buildfile: jboss-build.xml

db-insert:
[java] SQL Error at line 276: java.sql.SQLException: Wrong data type: Times
tamp format must be yyyy-mm-dd hh:mm:ss[.fffffffff]

BUILD SUCCESSFUL
Total time: 0 seconds
D:\duke's bank\j2eetutorial14\examples\bank>ant -f jboss-build.xml db-list
Buildfile: jboss-build.xml

db-list:
[java] ScriptTool.init error: sql\listAccount.sql (The system cannot find t
he file specified)
[java] java.io.FileNotFoundException: sql\listAccount.sql (The system canno
t find the file specified)
[java] at java.io.FileInputStream.open(Native Method)
[java] at java.io.FileInputStream.<init>(FileInputStream.java:106)
[java] at java.io.FileInputStream.<init>(FileInputStream.java:66)
[java] at java.io.FileReader.<init>(FileReader.java:41)
[java] at org.hsqldb.util.ScriptTool.execute(Unknown Source)
[java] at org.hsqldb.util.ScriptTool.main(Unknown Source)
[java] java.lang.NullPointerException
[java] at org.hsqldb.util.ScriptTool.fileToString(Unknown Source)
[java] at org.hsqldb.util.ScriptTool.execute(Unknown Source)
[java] at org.hsqldb.util.ScriptTool.main(Unknown Source)
[java] Exception in thread "main" java.lang.RuntimeException
[java] at org.hsqldb.util.ScriptTool.fileToString(Unknown Source)
[java] at org.hsqldb.util.ScriptTool.execute(Unknown Source)
[java] at org.hsqldb.util.ScriptTool.main(Unknown Source)
[java] Java Result: 1

BUILD SUCCESSFUL
Total time: 0 seconds


My hsqldb.xml file looks like this.

<?xml version="1.0" encoding="UTF-8"?>

<!-- The Hypersonic embedded database JCA connection factory config
$Id: hsqldb-ds.xml,v 1.15 2004/09/15 14:37:40 loubyansky Exp $ -->


<datasources>
<local-tx-datasource>

<!-- The jndi name of the DataSource, it is prefixed with java:/ -->
<!-- Datasources are not available outside the virtual machine -->
<jndi-name>DefaultDS</jndi-name>

<!-- for tcp connection, allowing other processes to use the hsqldb
database. This requires the org.jboss.jdbc.HypersonicDatabase mbean.-->
<connection-url>jdbc:hsqldb:hsql://localhost:1701</connection-url>

<!-- for totally in-memory db, not saved when jboss stops.
The org.jboss.jdbc.HypersonicDatabase mbean necessary
<connection-url>jdbc:hsqldb:.</connection-url>
-->
<!-- for in-process persistent db, saved when jboss stops. The
org.jboss.jdbc.HypersonicDatabase mbean is necessary for properly db shutdown

<connection-url>jdbc:hsqldb:${jboss.server.data.dir}${/}hypersonic${/}localDB</connection-url>
-->
<!-- The driver class -->
<driver-class>org.hsqldb.jdbcDriver</driver-class>

<!-- The login and password -->
<user-name>sa</user-name>
<password></password>

<!--example of how to specify class that determines if exception means connection should be destroyed-->
<!--exception-sorter-class-name>org.jboss.resource.adapter.jdbc.vendor.DummyExceptionSorter</exception-sorter-class-name-->

<!-- this will be run before a managed connection is removed from the pool for use by a client-->
<!--<check-valid-connection-sql>select * from something</check-valid-connection-sql> -->

<!-- The minimum connections in a pool/sub-pool. Pools are lazily constructed on first use -->
<min-pool-size>5</min-pool-size>

<!-- The maximum connections in a pool/sub-pool -->
<max-pool-size>20</max-pool-size>

<!-- The time before an unused connection is destroyed -->
<!-- NOTE: This is the check period. It will be destroyed somewhere between 1x and 2x this timeout after last use -->
<!-- TEMPORARY FIX! - Disable idle connection removal, HSQLDB has a problem with not reaping threads on closed connections -->
<idle-timeout-minutes>0</idle-timeout-minutes>

<!-- sql to call when connection is created
<new-connection-sql>some arbitrary sql</new-connection-sql>
-->

<!-- sql to call on an existing pooled connection when it is obtained from pool
<check-valid-connection-sql>some arbitrary sql</check-valid-connection-sql>
-->

<!-- example of how to specify a class that determines a connection is valid before it is handed out from the pool
<valid-connection-checker-class-name>org.jboss.resource.adapter.jdbc.vendor.DummyValidConnectionChecker</valid-connection-checker-class-name>
-->

<!-- Whether to check all statements are closed when the connection is returned to the pool,
this is a debugging feature that should be turned off in production -->
<track-statements/>

<!-- Use the getConnection(user, pw) for logins
<application-managed-security/>
-->

<!-- Use the security domain defined in conf/login-config.xml -->
<security-domain>HsqlDbRealm</security-domain>

<!-- Use the security domain defined in conf/login-config.xml or the
getConnection(user, pw) for logins. The security domain takes precedence.
<security-domain-and-application>HsqlDbRealm</security-domain-and-application>
-->

<!-- corresponding type-mapping in the standardjbosscmp-jdbc.xml (optional) -->
<metadata>
<type-mapping>Hypersonic SQL</type-mapping>
</metadata>

<!-- This mbean can be used when using in process persistent hypersonic -->
<depends>jboss:service=Hypersonic,database=localDB</depends>
</local-tx-datasource>

<!-- This mbean should be used only when using tcp connections. Uncomment
when the tcp based connection-url is used. -->
<mbean code="org.jboss.jdbc.HypersonicDatabase"
name="jboss:service=Hypersonic">
<attribute name="Port">1701</attribute>
<attribute name="Silent">true</attribute>
<attribute name="Database">default</attribute>
<attribute name="Trace">false</attribute>
<attribute name="No_system_exit">true</attribute>
</mbean>


<!-- This mbean can be used when using in process persistent db -->
<mbean code="org.jboss.jdbc.HypersonicDatabase"
name="jboss:service=Hypersonic,database=localDB">
<attribute name="Database">localDB</attribute>
<attribute name="InProcessMode">true</attribute>
</mbean>
</datasources>


please help me to get through this.

ZiYaVuDeEn JaVa
Greenhorn

Joined: Jan 06, 2010
Posts: 1
hai ,
I am Using the jBoss5.0 sever. when i start running my server,it is not running at all.It place to the position of Debug .never moves to next line in my console.Even i didn't add any project to it .the server alone doesn't start or go through.please give me solution.
thanks
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 9317
    
109

"ZiYaVuDeEn JaVa"

Please click on the "My Private Messages" link on top of this page, for a message from JavaRanch.

Also please do not post unrelated questions to someone else's thread. Create a new topic in this forum to discuss your question.

[My Blog] [JavaRanch Journal]
beata jane
Ranch Hand

Joined: Sep 10, 2009
Posts: 43
Is there any solution for the error i posted
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 9317
    
109


db-list:
[java] ScriptTool.init error: sql\listAccount.sql (The system cannot find t
he file specified)
[java] java.io.FileNotFoundException: sql\listAccount.sql (The system canno
t find the file specified)


As per the error message, there's a reference to sql\listAccount.sql which is not existent. So you have to fix the path to that file.

As a side note, JBoss 4.0.x is too old. I have never tried the Duke's example with JBoss so i don't exactly know what issue lies in there.
beata jane
Ranch Hand

Joined: Sep 10, 2009
Posts: 43
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\JESUS M REDEEMER>cd d:
D:\

C:\Documents and Settings\JESUS M REDEEMER>d:

D:\>cd dukesbank

D:\dukesbank>cd jbpm-bpel-1.1.1

D:\dukesbank\jbpm-bpel-1.1.1>cd examples

D:\dukesbank\jbpm-bpel-1.1.1\examples>ant test
Buildfile: build.xml

test:

test:

detect.wsdl:

get.published.wsdl:

BUILD FAILED
D:\dukesbank\jbpm-bpel-1.1.1\examples\build.xml:92: The following error occurred
while executing this line:
D:\dukesbank\jbpm-bpel-1.1.1\examples\build.xml:39: The following error occurred
while executing this line:
D:\dukesbank\jbpm-bpel-1.1.1\examples\common\mapping-build.xml:138: D:\dukesbank
\jbpm-bpel-1.1.1\examples\dukesbank\jboss-4.2.3.GA\server\default\data\wsdl\atm.
war not found.

Total time: 0 seconds
D:\dukesbank\jbpm-bpel-1.1.1\examples>



This is error which i have got....
And the get.published.wsdl file is in the mapping.xml ...
I have posted the mapping.xml file before...
Please let me what changes i have to make inorder to make it running sir.
beata jane
Ranch Hand

Joined: Sep 10, 2009
Posts: 43
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\JESUS M REDEEMER>cd d:
D:\

C:\Documents and Settings\JESUS M REDEEMER>d:

D:\>cd dukesbank

D:\dukesbank>cd jbpm-bpel-1.1.1

D:\dukesbank\jbpm-bpel-1.1.1>cd examples

D:\dukesbank\jbpm-bpel-1.1.1\examples>ant test
Buildfile: build.xml

test:

test:

detect.wsdl:

get.published.wsdl:

BUILD FAILED
D:\dukesbank\jbpm-bpel-1.1.1\examples\build.xml:92: The following error occurred
while executing this line:
D:\dukesbank\jbpm-bpel-1.1.1\examples\build.xml:39: The following error occurred
while executing this line:
D:\dukesbank\jbpm-bpel-1.1.1\examples\common\mapping-build.xml:138: D:\dukesbank
\jbpm-bpel-1.1.1\examples\dukesbank\jboss-4.2.3.GA\server\default\data\wsdl\atm.
war not found.

Total time: 0 seconds
D:\dukesbank\jbpm-bpel-1.1.1\examples>



This is the error i am getting in my command prompt sir.
The get.published.wsdl file is in the mapping.xml which i have posted earlier.
please let me know what changes i have to make inorder to make it running.
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5772
    
    7

I am locking this post because it is now tha same as what you posted at: http://www.coderanch.com/t/486159/JBoss/Error-ant-test-command
Please STOP OPENING MULTIPLE THREADS to discuss the same problem!!!


JBoss In Action
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: getting errors while running duke's bank application
 
Similar Threads
Connection Pooling
errors while compiling the ant script
I have problem in deploy j2eetutorial's Duke bank app in Jboss-4.0.2
CDATA problem???
JBOSS startup error