wood burning stoves 2.0*
The moose likes Struts and the fly likes unable to add tiles Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "unable to add tiles" Watch "unable to add tiles" New topic
Author

unable to add tiles

kranthidevarapalem kumar
Greenhorn

Joined: Dec 04, 2009
Posts: 6
Hi all
i am trying to add tiles to my struts project but i am getting the following error

This is my code
in struts-config.xml
---------------------------------
<plug-in className="org.apache.struts.tiles.TilesPlugin" >
<!-- Path to XML definition file -->
<set-property property="definitions-config" value="/WEB-INF/tiles-defs.xml" />
<!-- Set Module-awareness to true -->
<set-property property="moduleAware" value="true" />
</plug-in>
in tiles-defs.xml
-----------------------------------
<?xml version="1.0" encoding="ISO-8859-1" ?>

<!DOCTYPE tiles-definitions PUBLIC
"-//Apache Software Foundation//DTD Tiles Configuration 1.1//EN"
"http://jakarta.apache.org/struts/dtds/tiles-config_1_1.dtd">
<tiles-definitions>
<definition name="Login" page="Login.jsp">
<put name="header" value="header.jsp"/>
<put name="body" value="Loginmain.jsp"/>
<put name="footer" value="footer.jsp"/>
</definition>

</tiles-definitions>
in Login.jsp page
---------------------------------------

<%@ page language="java" import="java.util.*" pageEncoding="UTF-8"%>
<%@ taglib uri="/tags/struts-bean" prefix="bean"%>
<%@ taglib uri="/tags/struts-html" prefix="html"%>
<%@ taglib uri="/tags/struts-logic" prefix="logic"%>
<%@ taglib uri="http://struts.apache.org/tags-tiles" prefix="tiles" %>
<%
String path = request.getContextPath();
String basePath = request.getScheme()+"://"+request.getServerName()+":"+request.getServerPort()+path+"/";
%>

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<base href="<%=basePath%>">

<title>My JSP 'Login.jsp' starting page</title>

<meta http-equiv="pragma" content="no-cache">
<meta http-equiv="cache-control" content="no-cache">
<meta http-equiv="expires" content="0">
<meta http-equiv="keywords" content="keyword1,keyword2,keyword3">
<meta http-equiv="description" content="This is my page">

<!--
<link rel="stylesheet" type="text/css" href="styles.css">
-->
</head>

<body>

<table border="1" rows="2" cols="2" cellspacing="10" cellpadding="10" width="1000" height="600">

<tr><tiles:insert attribute="header"/></tr>

<tr><td align="left" width="350" height="550"><a href="Login.jsp">Home</a></td>

<td align="center" width="600" height="550">
<html:javascript formName="LoginBean"/>
<form method=POST action="./LoginAction.do?method=testdispatch" onsubmit="return validateLoginBean(form)">
<tiles:insert attribute="loginmain"/>

</form></td></tr>
</table>
<tiles:insert attribute="footer"/>
<br>
</body>
</html>

error is
----------------
HTTP Status 500 -

type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

org.apache.jasper.JasperException: An exception occurred processing JSP page /Login.jsp at line 34

31:
32: <table border="1" rows="2" cols="2" cellspacing="10" cellpadding="10" width="1000" height="600">
33:
34: <tr><tiles:insert attribute="header"/></tr>
35:
36: <tr><td align="left" width="350" height="550"><a href="Login.jsp">Home</a></td>
37:


Stacktrace:
org.apache.jasper.servlet.JspServletWrapper.handleJspException(JspServletWrapper.java:505)
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:416)
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342)
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267)
javax.servlet.http.HttpServlet.service(HttpServlet.java:717)

root cause

java.lang.NullPointerException
org.apache.struts.taglib.tiles.InsertTag.processAttribute(InsertTag.java:687)
org.apache.struts.taglib.tiles.InsertTag.createTagHandler(InsertTag.java:478)
org.apache.struts.taglib.tiles.InsertTag.doStartTag(InsertTag.java:438)
org.apache.jsp.Login_jsp._jspx_meth_tiles_005finsert_005f0(Login_jsp.java:150)
org.apache.jsp.Login_jsp._jspService(Login_jsp.java:105)
org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:374)
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342)
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267)
javax.servlet.http.HttpServlet.service(HttpServlet.java:717)

note The full stack trace of the root cause is available in the Apache Tomcat/6.0.20 logs.
Apache Tomcat/6.0.20

error in console is
---------------------------
SEVERE: Servlet.service() for servlet jsp threw exception
java.lang.NullPointerException
at org.apache.struts.taglib.tiles.InsertTag.processName(InsertTag.java:527)
at org.apache.struts.taglib.tiles.InsertTag.createTagHandler(InsertTag.java:482)
at org.apache.struts.taglib.tiles.InsertTag.doStartTag(InsertTag.java:438)
at org.apache.jsp.Login_jsp._jspx_meth_tiles_005finsert_005f0(Login_jsp.java:153)
at org.apache.jsp.Login_jsp._jspService(Login_jsp.java:108)
at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:374)
at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342)
at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:849)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:454)
at java.lang.Thread.run(Thread.java:619)


Thanks in advance

Kranthi
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: unable to add tiles
 
Similar Threads
java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory
NullPointerException on tiles
Struts 1.2 Cannot find bean org.apache.struts.taglib.html.BEAN
javax.servlet.jsp.JspException: Not nested in a tag of proper type.
can't find this error .i got this error in strut