This week's book giveaways are in the Java EE and JavaScript forums.
We're giving away four copies each of The Java EE 7 Tutorial Volume 1 or Volume 2(winners choice) and jQuery UI in Action and have the authors on-line!
See this thread and this one for details.
The moose likes Struts and the fly likes Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark ""Missing message for key" error!" Watch ""Missing message for key" error!" New topic
Author

"Missing message for key" error!

Dolfino Proteus
Greenhorn

Joined: Jan 12, 2010
Posts: 3
Hi all!

I'm making some changes to a web application that uses an ApplicationResources.properties file and "<bean:message ..." tag to take labels from it.
I only need to add a label on a jsp page where other labels are used.

I added a key-value pair in the .properties file:

The second line is mine, the first one was there before.
And then I used, of course, the struts tag:

If I use only the first one, it works fine, but when I add my label, it causes a "Missing message for key" error.

I really don't understand. Same .properties file, same syntax and I'm sure that I wrote the keys consinstently... where am I falling?!

Thank you all.
Dolfiz
Dolfino Proteus
Greenhorn

Joined: Jan 12, 2010
Posts: 3
Blame on me...

I'm developing on Eclipse and I switched off the auto-build feature... obviously every change I made was ignored by the application server that was deploying every time the same sources

Have a nice day all!
Dolfiz
 
Don't get me started about those stupid light bulbs.
 
subject: "Missing message for key" error!