aspose file tools*
The moose likes Linux / UNIX and the fly likes Spanish charset problem in Jboss in linux Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » Linux / UNIX
Reply locked New topic
Author

Spanish charset problem in Jboss in linux

Viiveek Sankar
Greenhorn

Joined: Jan 15, 2010
Posts: 4
hi,
I am having a problem with Spanish characters. My app server is jboss, os is linux and the charset iam using is UTF-8.
Iam using struts framework. All my java classes are compiled in UTF-8.
I have a form where i have to post some spanish data for e.g: Lácteos is a word in the post data.
I receive it as a request parameter in action class. When i print it in action class the accented character in the word turns into some strange character. which in turn messes up the rest of the code flow.
I am not having this problem in windows , its only in my dev environment which is linux.
I have to find a solution to this before i have to move it to QA or push alive.

I have tried a coupe of steps:-
I am forcing the java encoding to be UTF-8 in the java action files
All the Jsps are in UTF encoding.
During form post , I have forced form to accept UTF-8 encoding, but that didn’t work too


Please let me know if any of you have experienced such issues.

Thanks
Viiveek
Ankit Garg
Sheriff

Joined: Aug 03, 2008
Posts: 9313
    
  17

Duplicate Topic


SCJP 6 | SCWCD 5 | Javaranch SCJP FAQ | SCWCD Links
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Spanish charset problem in Jboss in linux