File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JBoss/WildFly and the fly likes Running JBoss 5.1.0 All Server Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Running JBoss 5.1.0 All Server" Watch "Running JBoss 5.1.0 All Server" New topic
Author

Running JBoss 5.1.0 All Server

Saikiran Madhavan
Greenhorn

Joined: May 15, 2006
Posts: 28
Hi,

I downloaded the JBOSS 5.1.0 GA server zip and tried to run the server (all). In my server log i am getting the below given error message



also my boot.log is


After this i tried running the default server and got the following log


default server.log



The server.log is as given below



both of them shows some error because of Transaction Manager configuration. I am not able to figure whats the issue is all about ???


Thanks in advance.

Saikiran
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5772
    
    7

One of the ways to almost guarantee that your post will not be answered is to overwhelm the readers with a ton of detail. Do you think that any of us are going to read all the stuff you posted? I sure am not. The only thing I looked at is the firs ERROR entry in the first log you posted, and I ignored everything else. Besides, Firefox complains that the scripts running on this page are becoming unresponsive due to the vast amounts of code you posted.

Anyway, the best way to track down an error is to follow the "caused by" links of the exception stack trace. Here is the root cause:

Caused by: java.lang.IllegalArgumentException: No such property transactionStatusManagerPort for bean com.arjuna.ats.jbossatx.jta.TransactionManagerService

I searched for "transactionStatusManagerPort, and even looked in the server/all/conf/jbossts-properties.xml where transaction properties are defined and could not find it. So what did you change or where did you set this port property?


JBoss In Action
Saikiran Madhavan
Greenhorn

Joined: May 15, 2006
Posts: 28
Peter.

Sorry. I did a copy paste in a hurry...I am not able to remove the post as well.

As for as your question is concerned. I too checked the property it is trying to set but didnt find it. also i am new to JBoss 5.1.0 GA. You have mentioned something about jbossts-properties.xml. I am not aware of this xml configuration.

Also when i run the same thing in default server - in the server log i am getting a different exception stack trace



i found this property in the server/default/deploy/transaction-jboss-beans.xml but i am not sure what to set and how its working. also i found socketProcessIdPort in com.arjuna.ats.jbossatx.jta.TransactionManagerService bean in the bean definition file C:\jboss-5.1.0.GA\server\default\deploy\transaction-jboss-beans.xml. The value of this property is set as 0 and i just changed it into some number. But nothing changed because of that.

Any clue why i am getting this error, and is it because of the JbossTS configuration?

Thanks
Saikiran
 
jQuery in Action, 2nd edition
 
subject: Running JBoss 5.1.0 All Server
 
Similar Threads
Deployment error of ear in jboss
I use JBoss 5.0.1 in Eclipse but If I stat jboss in eclipse it throw exception follows.
[AbstractKernelController] Error installing to Instantiated: name=TransactionManager
JBoss 5.1.0.GA startup error messages
ExceptionInInitializerError while running servlet in JBoss 5.0