wood burning stoves 2.0*
The moose likes BEA/Weblogic and the fly likes Missing Auto Deploy Folder in Domain Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Missing Auto Deploy Folder in Domain" Watch "Missing Auto Deploy Folder in Domain" New topic
Author

Missing Auto Deploy Folder in Domain

Praneet Mirchandani
Ranch Hand

Joined: Dec 16, 2009
Posts: 46

Hi,

I have created a new domain in weblogic through the WebLogic configuration wizard. These are the steps I have followed:

I have selected "Base this domain on an existing template option" and specified the location of a JAR file.
Then entered the user name, password, etc.
Then selected Development mode option, and BEA supplied JDKs option. In BEA supplied option, I have selected Sun SDK 1.5.0_10.
Then selected NO for "Do you want to customize any options?"
Then entered name and location of domain.
Then created the domain.

Now the problem is that there is no autodeploy folder created in the domain. So where do I paste the WAR file to deploy the application.

Please help..

Praneet


Thanks,
Praneet
Deepak Bala
Bartender

Joined: Feb 24, 2006
Posts: 6661
    
    5

You can mention the WAR file location when you deploy the application


SCJP 6 articles - SCJP 5/6 mock exams - More SCJP Mocks
Praneet Mirchandani
Ranch Hand

Joined: Dec 16, 2009
Posts: 46

Hi Deepak,

I am not exactly sure how that is done. Could you please elaborate.

Thanks,
Praneet
Deepak Bala
Bartender

Joined: Feb 24, 2006
Posts: 6661
    
    5

Detailed information available here -> http://download.oracle.com/docs/cd/E13222_01/wls/docs100/webapp/index.html
Joseph Antoine Raja
Ranch Hand

Joined: Feb 01, 2010
Posts: 32
Hi Praneet,

The Auto Deploy option is only available for the domains that have been created in DEVELOPMENT Mode. If you create a domain in PRODUCTION Mode then auto deploy option won't be available.

You can start your Admin server in DEV mode by using
-Dweblogic.ProductionModeEnabled={true/false} D Option
 
jQuery in Action, 2nd edition
 
subject: Missing Auto Deploy Folder in Domain
 
Similar Threads
Running JSP in Weblogic 8.1 afer creating a NEW Domain.
Weblogic 8.1 - Deploy EAR into exploded archive
Installing jsr-168 portlets on BEA WPS
deploying webapplication
getting problem in deploying application on server...