aspose file tools*
The moose likes Struts and the fly likes Cannot generate classes after inserting Struts stuff Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Cannot generate classes after inserting Struts stuff" Watch "Cannot generate classes after inserting Struts stuff" New topic
Author

Cannot generate classes after inserting Struts stuff

Leandro Melo
Ranch Hand

Joined: Mar 27, 2004
Posts: 401
Hi,
my app was generating class files alright until i was
in EJB tier development.
When i got to WEB tier, i decided to go with Struts.
Created a couple JSPs, ActionForms and Actions
(without modifying EJBs) and run it. Everything is ok
till that point.
Then, i came back to EJB development again and for the
first time a tried to generate classes after including
Struts stuff in project, i got the following message
from my xdoclet generation.
ejbdoclet:
[ejbdoclet] BUILD FAILED: org.apache.commons.logging.LogConfigurationException:
java.lang.ClassNotFoundException:
org.easystruts.struts.config.EasyStrutsLogFactory

I took a look at xdoclet.xml file and saw this piece
of commented code.

I don't have any struts generated form by EJBs (i
generate them with EasyStruts).
I don't know what is going on, can anyone help me
here???
Thanks,
ltcmelo
Arv Rao
Greenhorn

Joined: May 19, 2004
Posts: 3
how did you do it?

I am having same problem

please reply fast
Carlos Cajina
Greenhorn

Joined: Jun 07, 2004
Posts: 1
Hi everyone.

Here's a little recipe that worked for me (I'm using Eclipse 2.1.3, Lomboz 213 and EasyStruts 0.70RC1, but it should work well with other versions)

1. Just in case, comment <strutsform /> in <EJB_MODULE>/META-INF/xdoclet.xml

2. In the same file, look for <fileset dir="${eclipse.home}/plugins">

3. After <include name="**/com.objectlearn.*/**/jakarta/*.jar"/> add the line <include name="**/com.cross.easystruts.*/**/*.jar"/>

This should add the easystruts.jar file to the classpath and prevent the EasyStrutsLogFactory error, 'cause the "missing" class is in that jar.

Good Luck!!!
Ken Loh
Ranch Hand

Joined: Feb 16, 2005
Posts: 190
Sorry for digging up a probably dead thread, but I encountered the same problem and I discovered that it was due to my malformed struts-config.xml ! An <action> tag had a missing </action>.

Just like to add my 2-cents worth.

Thanks,
Ken
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Cannot generate classes after inserting Struts stuff