aspose file tools*
The moose likes Ant, Maven and Other Build Tools and the fly likes Ant Build Successful but neither jar file nor build folder created ? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » Ant, Maven and Other Build Tools
Bookmark "Ant Build Successful but neither jar file nor build folder created ?" Watch "Ant Build Successful but neither jar file nor build folder created ?" New topic
Author

Ant Build Successful but neither jar file nor build folder created ?

Prabhat Ranjan
Ranch Hand

Joined: Oct 04, 2006
Posts: 391
Hi,

I am building a project using only 1 file to test for Ant.

This is my code:



But i don't see any output in the director or even directory created.

Here is successful build output:

Buildfile: C:\Workspace_log4j\testLog4j\build.xml
BUILD SUCCESSFUL
Total time: 63 milliseconds


Also i am attaching the directory structure of the Project.




[Thumbnail for Ant_Build.jpg]

Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10266
    
168

What target are you running? I don't see any default target in your build file. Also the output you posted is just the last couple of lines. Please post the rest of the relevant output.


[My Blog] [JavaRanch Journal]
Prabhat Ranjan
Ranch Hand

Joined: Oct 04, 2006
Posts: 391
Buildfile: C:\Workspace_log4j\testLog4j\build.xml
BUILD SUCCESSFUL
Total time: 78 milliseconds


This is the complete output here from console.
David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

So, what target are you running? Maybe try running a target. Or setting a default target.
Prabhat Ranjan
Ranch Hand

Joined: Oct 04, 2006
Posts: 391
I think i am using the defult target !
David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

Which is...?
Prabhat Ranjan
Ranch Hand

Joined: Oct 04, 2006
Posts: 391
I don't know exacty and it could be the workspace_xyz and then the build folder.
David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

*Ant* target. What task do you think is running? Have you trying specifying one?
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5843
    
    7

There is no default target in ant and you have not specified one in the <project> statement, so if you do not specify a target on the command line then ant will do nothing. And as it reported, is was successful at doing nothing.


JBoss In Action
Prabhat Ranjan
Ranch Hand

Joined: Oct 04, 2006
Posts: 391



the above code is working.
David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

Please UseCodeTags when posting code or configuration. Unformatted code and configuration is unnecessarily difficult to read.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Ant Build Successful but neither jar file nor build folder created ?