Win a copy of Think Java: How to Think Like a Computer Scientist this week in the Java in General forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

cannot install maven for eclipse

 
Vicky Johnny
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Am having issues with installing Maven 0.9.8 for Eclipse 3.4.2

Am using the update site : http://m2eclipse.sonatype.org/update/

Getting the foll. error:

Cannot complete the request. See the details.
Cannot find a solution satisfying the following requirements org.eclipse.ltk.core.refactoring [3.4.2.r342_v20081028-0800].

Any solution?
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
0.9.8?!?! Why? I don't even know if the plugins would work for such an old version.
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
In the Eclipse update dialog did you choose the correct version of m2eclipse that works with 3.4.2? The m2eclipse versions are typically tied to the version of Eclipse, so 0.9.8 might not be the right one (I don't have a copy of Eclipse 3.4.2 to check, but for Eclipse 3.5 the m2eclipse version is 0.9.9, so you probably have the correct one).

The other possibility is that you select one of the m2eclipse software options that has some requirement. Exactly which items did you select in the Available Software dialog?

 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Oh, the version of the plugin. That's a lot different--my mistake.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic