• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

WLS - wldeploy

 
Oliver Baum
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I try to deploy an application to WLS 9.2 with the ANT TASK <wldeploy>. It works.

But when I try to use the SSL port from the server, I cannot connect to the server. How can I deploy to WEBLOGIC with ANT Tasks to use the SSL PORT?

Thanks for help
 
Deepak Bala
Bartender
Posts: 6663
5
Firefox Browser Linux MyEclipse IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Do you get an error ? Post that here along with the command used in ant
 
Joseph Antoine Raja
Ranch Hand
Posts: 32
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Oliver,

I belive for the WLS Deployment Admin can be connected using only 2 protocols http/t3

Please find the wldeploy documentation

http://download.oracle.com/docs/cd/E11035_01/wls100/programming/wldeploy.html

 
Oliver Baum
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Good morining,

I agree the the wldeploy only can be connect using the protocols http/t3.

But how can I deploy to WLS with ant over SSL?




the task looks:
<wldeploy
action="deploy"
adminurl="${url}"
targets="${targets}"
user="${username}"
password="${pass}"
debug="${debug}"
name="${webapp}"
source="${webapp.path}"
upload="${upload}"
verbose="${verbose}"
library="${library}"
nostage="${nostage}" />


And the error:

[wldeploy] weblogic.Deployer -debug -verbose -upload -noexit -name idm -source
C:\prj\IDM\image\idm.war -targets MSIDM01 -adminurl t3s://t68idm1.wwk-group.com:
27047 -user weblogic -password ******** -deploy
[wldeploy] weblogic.Deployer invoked with options: -debug -verbose -upload -no
exit -name idm -source C:\prj\IDM\image\idm.war -targets MSIDM01 -adminurl t3s:/
/t68idm1.wwk-group.com:27047 -user weblogic -deploy
[wldeploy] weblogic.deploy.api.tools.deployer.DeployerException: Unable to conn
ect to 't3s://t68idm1.wwk-group.com:27047': Exception occurred while reading the
license file.. Ensure the url represents a running admin server and that the cr
edentials are correct. If using http protocol, tunneling must be enabled on the
admin server.
[wldeploy] at weblogic.deploy.api.tools.deployer.Jsr88Operation.connect(Jsr
88Operation.java:314)
[wldeploy] at weblogic.deploy.api.tools.deployer.Deployer.perform(Deployer.
java:137)
[wldeploy] at weblogic.deploy.api.tools.deployer.Deployer.runBody(Deployer.
java:88)
[wldeploy] at weblogic.utils.compiler.Tool.run(Tool.java:158)
[wldeploy] at weblogic.utils.compiler.Tool.run(Tool.java:115)
[wldeploy] at weblogic.Deployer.run(Deployer.java:70)
[wldeploy] at weblogic.Deployer.mainWithExceptions(Deployer.java:62)
[wldeploy] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[wldeploy] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcces
sorImpl.java:39)
[wldeploy] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMet
hodAccessorImpl.java:25)
[wldeploy] at java.lang.reflect.Method.invoke(Method.java:585)
[wldeploy] at weblogic.ant.taskdefs.management.WLDeploy.invokeMain(WLDeploy
.java:419)
[wldeploy] at weblogic.ant.taskdefs.management.WLDeploy.execute(WLDeploy.ja
va:349)
[wldeploy] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.ja
va:288)
[wldeploy] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[wldeploy] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcces
sorImpl.java:39)
[wldeploy] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMet
hodAccessorImpl.java:25)
[wldeploy] at java.lang.reflect.Method.invoke(Method.java:585)
[wldeploy] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchU
tils.java:105)
[wldeploy] at org.apache.tools.ant.Task.perform(Task.java:348)
[wldeploy] at org.apache.tools.ant.Target.execute(Target.java:357)
[wldeploy] at org.apache.tools.ant.Target.performTasks(Target.java:385)
[wldeploy] at org.apache.tools.ant.Project.executeSortedTargets(Project.jav
a:1329)
[wldeploy] at org.apache.tools.ant.Project.executeTarget(Project.java:1298)

[wldeploy] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(De
faultExecutor.java:41)
[wldeploy] at org.apache.tools.ant.Project.executeTargets(Project.java:1181
)
[wldeploy] at org.apache.tools.ant.Main.runBuild(Main.java:758)
[wldeploy] at org.apache.tools.ant.Main.startAnt(Main.java:217)
[wldeploy] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
[wldeploy] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
[wldeploy] Caused by: javax.enterprise.deploy.spi.exceptions.DeploymentManagerC
reationException: [J2EE Deployment SPI:260009]Exception caught for class 'weblog
ic.deploy.api.spi.deploy.internal.ServerConnectionImpl' while attempting to crea
te DeploymentManager: java.lang.RuntimeException: Exception occurred while readi
ng the license file.

Thanks
Oliver
 
Hari Prasad.B
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Oliver Baum wrote:Good morining,

I agree the the wldeploy only can be connect using the protocols http/t3.

But how can I deploy to WLS with ant over SSL?




the task looks:
<wldeploy
action="deploy"
adminurl="${url}"
targets="${targets}"
user="${username}"
password="${pass}"
debug="${debug}"
name="${webapp}"
source="${webapp.path}"
upload="${upload}"
verbose="${verbose}"
library="${library}"
nostage="${nostage}" />


And the error:

[wldeploy] weblogic.Deployer -debug -verbose -upload -noexit -name idm -source
C:\prj\IDM\image\idm.war -targets MSIDM01 -adminurl t3s://t68idm1.wwk-group.com:
27047 -user weblogic -password ******** -deploy
[wldeploy] weblogic.Deployer invoked with options: -debug -verbose -upload -no
exit -name idm -source C:\prj\IDM\image\idm.war -targets MSIDM01 -adminurl t3s:/
/t68idm1.wwk-group.com:27047 -user weblogic -deploy
[wldeploy] weblogic.deploy.api.tools.deployer.DeployerException: Unable to conn
ect to 't3s://t68idm1.wwk-group.com:27047': Exception occurred while reading the
license file.. Ensure the url represents a running admin server and that the cr
edentials are correct. If using http protocol, tunneling must be enabled on the
admin server.
[wldeploy] at weblogic.deploy.api.tools.deployer.Jsr88Operation.connect(Jsr
88Operation.java:314)
[wldeploy] at weblogic.deploy.api.tools.deployer.Deployer.perform(Deployer.
java:137)
[wldeploy] at weblogic.deploy.api.tools.deployer.Deployer.runBody(Deployer.
java:88)
[wldeploy] at weblogic.utils.compiler.Tool.run(Tool.java:158)
[wldeploy] at weblogic.utils.compiler.Tool.run(Tool.java:115)
[wldeploy] at weblogic.Deployer.run(Deployer.java:70)
[wldeploy] at weblogic.Deployer.mainWithExceptions(Deployer.java:62)
[wldeploy] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[wldeploy] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcces
sorImpl.java:39)
[wldeploy] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMet
hodAccessorImpl.java:25)
[wldeploy] at java.lang.reflect.Method.invoke(Method.java:585)
[wldeploy] at weblogic.ant.taskdefs.management.WLDeploy.invokeMain(WLDeploy
.java:419)
[wldeploy] at weblogic.ant.taskdefs.management.WLDeploy.execute(WLDeploy.ja
va:349)
[wldeploy] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.ja
va:288)
[wldeploy] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[wldeploy] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcces
sorImpl.java:39)
[wldeploy] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMet
hodAccessorImpl.java:25)
[wldeploy] at java.lang.reflect.Method.invoke(Method.java:585)
[wldeploy] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchU
tils.java:105)
[wldeploy] at org.apache.tools.ant.Task.perform(Task.java:348)
[wldeploy] at org.apache.tools.ant.Target.execute(Target.java:357)
[wldeploy] at org.apache.tools.ant.Target.performTasks(Target.java:385)
[wldeploy] at org.apache.tools.ant.Project.executeSortedTargets(Project.jav
a:1329)
[wldeploy] at org.apache.tools.ant.Project.executeTarget(Project.java:1298)

[wldeploy] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(De
faultExecutor.java:41)
[wldeploy] at org.apache.tools.ant.Project.executeTargets(Project.java:1181
)
[wldeploy] at org.apache.tools.ant.Main.runBuild(Main.java:758)
[wldeploy] at org.apache.tools.ant.Main.startAnt(Main.java:217)
[wldeploy] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
[wldeploy] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
[wldeploy] Caused by: javax.enterprise.deploy.spi.exceptions.DeploymentManagerC
reationException: [J2EE Deployment SPI:260009]Exception caught for class 'weblog
ic.deploy.api.spi.deploy.internal.ServerConnectionImpl' while attempting to crea
te DeploymentManager: java.lang.RuntimeException: Exception occurred while readi
ng the license file.

Thanks
Oliver


Hi Oliver,

You have to install ssl to communicate with t3s protocal.Configure SSL for your admin server and try with t3s.

Thanks,
Hari
 
Hari Prasad.B
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Oliver Baum wrote:Good morining,

I agree the the wldeploy only can be connect using the protocols http/t3.

But how can I deploy to WLS with ant over SSL?




the task looks:
<wldeploy
action="deploy"
adminurl="${url}"
targets="${targets}"
user="${username}"
password="${pass}"
debug="${debug}"
name="${webapp}"
source="${webapp.path}"
upload="${upload}"
verbose="${verbose}"
library="${library}"
nostage="${nostage}" />


And the error:

[wldeploy] weblogic.Deployer -debug -verbose -upload -noexit -name idm -source
C:\prj\IDM\image\idm.war -targets MSIDM01 -adminurl t3s://t68idm1.wwk-group.com:
27047 -user weblogic -password ******** -deploy
[wldeploy] weblogic.Deployer invoked with options: -debug -verbose -upload -no
exit -name idm -source C:\prj\IDM\image\idm.war -targets MSIDM01 -adminurl t3s:/
/t68idm1.wwk-group.com:27047 -user weblogic -deploy
[wldeploy] weblogic.deploy.api.tools.deployer.DeployerException: Unable to conn
ect to 't3s://t68idm1.wwk-group.com:27047': Exception occurred while reading the
license file.. Ensure the url represents a running admin server and that the cr
edentials are correct. If using http protocol, tunneling must be enabled on the
admin server.
[wldeploy] at weblogic.deploy.api.tools.deployer.Jsr88Operation.connect(Jsr
88Operation.java:314)
[wldeploy] at weblogic.deploy.api.tools.deployer.Deployer.perform(Deployer.
java:137)
[wldeploy] at weblogic.deploy.api.tools.deployer.Deployer.runBody(Deployer.
java:88)
[wldeploy] at weblogic.utils.compiler.Tool.run(Tool.java:158)
[wldeploy] at weblogic.utils.compiler.Tool.run(Tool.java:115)
[wldeploy] at weblogic.Deployer.run(Deployer.java:70)
[wldeploy] at weblogic.Deployer.mainWithExceptions(Deployer.java:62)
[wldeploy] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[wldeploy] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcces
sorImpl.java:39)
[wldeploy] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMet
hodAccessorImpl.java:25)
[wldeploy] at java.lang.reflect.Method.invoke(Method.java:585)
[wldeploy] at weblogic.ant.taskdefs.management.WLDeploy.invokeMain(WLDeploy
.java:419)
[wldeploy] at weblogic.ant.taskdefs.management.WLDeploy.execute(WLDeploy.ja
va:349)
[wldeploy] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.ja
va:288)
[wldeploy] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[wldeploy] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcces
sorImpl.java:39)
[wldeploy] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMet
hodAccessorImpl.java:25)
[wldeploy] at java.lang.reflect.Method.invoke(Method.java:585)
[wldeploy] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchU
tils.java:105)
[wldeploy] at org.apache.tools.ant.Task.perform(Task.java:348)
[wldeploy] at org.apache.tools.ant.Target.execute(Target.java:357)
[wldeploy] at org.apache.tools.ant.Target.performTasks(Target.java:385)
[wldeploy] at org.apache.tools.ant.Project.executeSortedTargets(Project.jav
a:1329)
[wldeploy] at org.apache.tools.ant.Project.executeTarget(Project.java:1298)

[wldeploy] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(De
faultExecutor.java:41)
[wldeploy] at org.apache.tools.ant.Project.executeTargets(Project.java:1181
)
[wldeploy] at org.apache.tools.ant.Main.runBuild(Main.java:758)
[wldeploy] at org.apache.tools.ant.Main.startAnt(Main.java:217)
[wldeploy] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
[wldeploy] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
[wldeploy] Caused by: javax.enterprise.deploy.spi.exceptions.DeploymentManagerC
reationException: [J2EE Deployment SPI:260009]Exception caught for class 'weblog
ic.deploy.api.spi.deploy.internal.ServerConnectionImpl' while attempting to crea
te DeploymentManager: java.lang.RuntimeException: Exception occurred while readi
ng the license file.

Thanks
Oliver


Hi Oliver,

You have to install ssl to communicate with t3s protocal.Configure SSL for your admin server and try with t3s.

Thanks,
Hari
 
Oliver Baum
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
we have already configured the SSL Admin Port in the WLS.

Thanks
 
Deepak Bala
Bartender
Posts: 6663
5
Firefox Browser Linux MyEclipse IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are you able to confirm that t3s services are available at port 27047 ?
 
Oliver Baum
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes, the t3s services are available at port 27047.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic