aspose file tools*
The moose likes Struts and the fly likes Issue: Form bean not being populated. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Issue: Form bean not being populated." Watch "Issue: Form bean not being populated." New topic
Author

Issue: Form bean not being populated.

Rajkamal Pillai
Ranch Hand

Joined: Mar 02, 2005
Posts: 443
    
    1

Hello,

I am using Struts 1.2 and JDK 1.5 for a project I am working on. I have declared my <html:form> with action=XXX and in the struts-config the <action> is defined by the same path. In the same tag I have a name attribute specifying the Form Bean associated with this Action. When the request reaches the execute method the ActionForm is an instance of this derivative but the values chosen are not being populated in the Form Bean. This particular Form has multiple <html:select>. I am not able to get the values chosen for any of the select boxes.

Could you help me with this?
Rajkamal Pillai
Ranch Hand

Joined: Mar 02, 2005
Posts: 443
    
    1

Checked the log files and there is an exception occurring. Its "No FormBeanConfig found under 'XXX'." Now that is confusing as the type of the FormBean I get in the execute() method is the one as declared in the <form-bean> definition.

My <action> is thus:-



This is my <form-bean>


Could someone please help me out?

Cheers,
Raj.
 
 
subject: Issue: Form bean not being populated.