aspose file tools*
The moose likes JSF and the fly likes Simple Application Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Java » JSF
Bookmark "Simple Application" Watch "Simple Application" New topic
Author

Simple Application

Servo Alvo
Greenhorn

Joined: Jan 13, 2010
Posts: 24
I´ve got a 404 error in this app:


FACES-CONFIG.XML:




WEB.XML:





LOGIN.JSP:





FRONTSTORE.JSP:





INDEX.HTML:





When I try to access (via http://localhost:8080/14_store_faces ) I get this error:

HTTP Status 404 - /index.faces not found

What could it be?

I just checked folder structures and it´s all right. All JSF libs are present too.



Sumeet Singh Aryan
Ranch Hand

Joined: Jul 30, 2008
Posts: 43
hi,

do you have any index.hrml page in your project?? if it is not then your first step is to create it and be sure that it will be created in a right position


The woods are lovely, dark and deep, But I have promises to keep; And miles to go before I sleep, And miles to go before I sleep. - Robert Frost
Sumeet Singh Aryan
Ranch Hand

Joined: Jul 30, 2008
Posts: 43
sorry that was index.html page... it's typo error
Servo Alvo
Greenhorn

Joined: Jan 13, 2010
Posts: 24
so what might it could be ?
Servo Alvo
Greenhorn

Joined: Jan 13, 2010
Posts: 24
Up....
Tejas Aj
Greenhorn

Joined: Feb 10, 2010
Posts: 6
Hi,
so did you resolve this?

Thanks,
Tejas.
Servo Alvo
Greenhorn

Joined: Jan 13, 2010
Posts: 24
Unfortunatelly not!
Servo Alvo
Greenhorn

Joined: Jan 13, 2010
Posts: 24
Up...
Misha Ver
Ranch Hand

Joined: Mar 03, 2008
Posts: 470
Servo Alvo wrote:

INDEX.HTML:



Change index.faces to login.jsp
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Simple Application
 
Similar Threads
problem on JSF application
my first jsf app is giving error, can someone please help me!
Navigation problem
navigation rules are not working...
Problems with running JSF in Eclipse 3.1