wood burning stoves 2.0*
The moose likes IDEs, Version Control and other tools and the fly likes taglib problem in Netbeans Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "taglib problem in Netbeans" Watch "taglib problem in Netbeans" New topic
Author

taglib problem in Netbeans

Samanthi perera
Ranch Hand

Joined: Jan 08, 2010
Posts: 510
I am using Netbeans 6.7 version

this is my java class


this is my tld file


this is my tag file


but i have got error in line <%@ taglib prefix="myTags" uri="simpleTags" %> at tag file saying "file /simpleTags not found"

Samanthi perera
Ranch Hand

Joined: Jan 08, 2010
Posts: 510
I tried to attach error screenshot,but unfortuantly i am unable.
so i have added it as a url.
I am remember here someone says don't use URLs.But i don't have way to show my error.
So please answer my question

http://3.bp.blogspot.com/_bpkZ2BsqXug/S3bqTv40e_I/AAAAAAAAAHM/1Wasgaea1ic/s1600-h/er.GIF
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 60048
    
  65

Samanthi perera wrote:But i don't have way to show my error.

What keeps you from cutting and pasting the error text like everyone else?


[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 60048
    
  65

But just looking at your code: look carefully at your TLD file. I mean really carefully. What's wrong with it?
Samanthi perera
Ranch Hand

Joined: Jan 08, 2010
Posts: 510
still i am unable to find the error??
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 60048
    
  65

What URI do you declare for your TLD?
Samanthi perera
Ranch Hand

Joined: Jan 08, 2010
Posts: 510
simpleTags
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 60048
    
  65

Really? I see:


You are not paying attention to detail!
Samanthi perera
Ranch Hand

Joined: Jan 08, 2010
Posts: 510
now this is my TLD file


this is my jsp


now it gives error on jsp line "<%@ taglib prefix="myTags" uri="simpleTags" %>"
it says file simpleTags not found
here is screeenshot

http://3.bp.blogspot.com/_bpkZ2BsqXug/S3eH8J2NV_I/AAAAAAAAAHU/DTqiJfbixwg/s1600-h/tag.GIF
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 60048
    
  65

The URIs must match. And it would be best to follow the correct pattern for a URI, which should look like URL (but isn't).
Samanthi perera
Ranch Hand

Joined: Jan 08, 2010
Posts: 510
this is my tld class


here is the path of tag file SCWCD\web \WEB-INF\simple.tld


this is my jsp


here is path of jsp
SCWCD\web\MyTag.jsp
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 60048
    
  65

Can you not do a simple comparison to see if two strings of characters match? For the last time, the URIs must match.

And again, please do not post links to GIFs of your errors. Type them into the post. I have removed the link.

What happens when future searches look at this topic and the links no longer are valid?
Samanthi perera
Ranch Hand

Joined: Jan 08, 2010
Posts: 510
I have change the tld files uri to <uri>/WEB-INF/simpleTags</uri> .
But error is still same and there.?
it says unable to load tag handler class foo.SimpleTagTest1 for tag mytags.simple1
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 60048
    
  65

Where is the class file for foo.SimpleTagTest1?
Samanthi perera
Ranch Hand

Joined: Jan 08, 2010
Posts: 510
I am using Netbeans IDE.I don't copy it to anywhere.
Java file is in foo\SimpleTagTest1.java
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 60048
    
  65

Moved to the IDEs forum.
Samanthi perera
Ranch Hand

Joined: Jan 08, 2010
Posts: 510
how to find a class files in netbeans IDE
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: taglib problem in Netbeans
 
Similar Threads
Simple Tag
Why in tld,you need add attribute type?
Setting bean in Simple tag attribute
cannot find the declaration of element taglib
CustomTag