aspose file tools*
The moose likes I/O and Streams and the fly likes Parallel port IO problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Java » I/O and Streams
Bookmark "Parallel port IO problem" Watch "Parallel port IO problem" New topic
Author

Parallel port IO problem

M. Sunil
Greenhorn

Joined: Mar 24, 2009
Posts: 8
Hi,

I am trying to write into the parallel port using rxtx jars. The opening of the port is fine but when it comes to writing it somehow detects that there is no device connected. I am trying to use a mutlimeter to detect the data bits[using pins 2 ,3 ,..] [high and low]. So can somebody tell me how i can run the program without getting this exception.
'Thanks,
Joe Ess
Bartender

Joined: Oct 29, 2001
Posts: 8927
    
    9

M. Sunil wrote: it somehow detects that there is no device connected.


Let me get this straight: you are attempting to write data to a port without a device? That should fail.
If you want to test what would happen if you actually attached something, you would need a parallel port loopback device.


"blabbing like a narcissistic fool with a superiority complex" ~ N.A.
[How To Ask Questions On JavaRanch]
M. Sunil
Greenhorn

Joined: Mar 24, 2009
Posts: 8
Yes. I am trying to write into a port to which no device is connected. Is there any way to make the driver believe that there is a device connected. Say by pushing some pins to high. I have a dll and a program in c# to write to the port and it works. i have tested it with a multi meter.
Thanks,.
 
Don't get me started about those stupid light bulbs.
 
subject: Parallel port IO problem