aspose file tools*
The moose likes JBoss/WildFly and the fly likes reslove this problem please Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "reslove this problem please" Watch "reslove this problem please" New topic
Author

reslove this problem please

kishore nag
Greenhorn

Joined: Feb 18, 2010
Posts: 17
iam installing jboss in myeclipse 7.5

i have proect that was in tomacat 5.0 ,,that is working fine in that project we have jpa hibernate ,,

and our project store first persitence.xml first after finish this persitence.xml then i load our project main page...

and my issue is when i deploy the jboss now iam getting this error.

and my persitence.xml look like this


Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10202
    
166

kishore,

While posting logs or xml content or code, please remember to wrap it in a code block by using the Code button in the message editor window. Please use the Preview button to ensure that your post is correctly formatted. I have fixed your post for now.

As for the error:
Caused by: org.jboss.xb.binding.JBossXBException: Failed to parse source: cvc-complex-type.2.4.a: Invalid content was found starting with element 'property'. One of '{"http://java.sun.com/xml/ns/persistence":jta-data-source, "http://java.sun.com/xml/ns/persistence":non-jta-data-source, "http://java.sun.com/xml/ns/persistence":mapping-file, "http://java.sun.com/xml/ns/persistence":jar-file, "http://java.sun.com/xml/ns/persistence":class, "http://java.sun.com/xml/ns/persistence":exclude-unlisted-classes, "http://java.sun.com/xml/ns/persistence":properties}' is expected. @ vfsfile:/C:/openlogic-jboss-5.1.0.GA-all-bin-1/jboss-5.1.0.GA/server/default/deploy/iportman.war/WEB-INF/classes/META-INF/persistence.xml[10,101]


Looks like the persistence.xml is not following the xsd. Line number 10 (specifically). By the way, are you sure the persistence.xml that you posted here, is the one that is running into problems? The line number 10 in the file you posted doesn't contain any "property" element.

[My Blog] [JavaRanch Journal]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: reslove this problem please