File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes IDEs, Version Control and other tools and the fly likes debug question in netBeans Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "debug question in netBeans" Watch "debug question in netBeans" New topic
Author

debug question in netBeans

adam smith ii
Greenhorn

Joined: Feb 04, 2010
Posts: 20
Hello,
I am trying to debug following code and I am unable to see program variables when I run the program in debug mode. Please explain reason for messages and corrective action required.



Output window contains following:


Variables output window included as a jpeg attachment. What does the message,
No variables to display because there is no current thread.
mean?

Also the messages
>No current context (stack frame)<


thanks in advance.





[Thumbnail for debug variables not visiable.JPG]

adam smith ii
Greenhorn

Joined: Feb 04, 2010
Posts: 20
I think I determined that when the system is waiting for input, the current thread is not visible. I needed a breakpoint to see current thread information.
However, I still do not understand the messages:


in the "debug" window.
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5836
    
    7

Check the libraries for your project, or check the JDK configuration settings for these two entries and remove them. Essentially, the error message means that that file and directory could not be found, which is not surprising since they don't exist.


JBoss In Action
adam smith ii
Greenhorn

Joined: Feb 04, 2010
Posts: 20
Peter,
You got me looking in the right place, but...

The libraries are introduced when I use, Tools, Java Platforms (see attached pic.)

I tried to "Add Platform" and the same 2 missing objects a jar & a directory lines are included (items 3 & 7 in Platform Classpath panel).

Could there be a problem with the JDK build I have?





[Thumbnail for netbeans java platform manager.JPG]

adam smith ii
Greenhorn

Joined: Feb 04, 2010
Posts: 20
(found on Google)
I too have the same problem. What is interesting that I still have NetBeans
6.7 and the newest 6.8.
6.7 runs without a hitch and 6.8 gives the error.

I think it is some sort of red herring, but I don't like errors.

I found the sunrsaign.jar in C:\Program Files\NetBeans 6.8\mobility8\Java_ME_platform_SDK_3.0,
so I just copied it into C:\Program Files\Java\jdk1.6.0\jre\lib

Likewise I created a folder called classes in C:\Program
Files\Java\jdk1.6.0\jre.

Now NetBeans is happy and I am happy not to see these error messages.

Ilan
--
View this message in context: http://old.nabble.com/Error-on-project-debbuging-tp26785093p26807921.html
Sent from the Netbeans IDE Users mailing list archive at Nabble.com.
Back to top

Problem solved, thanks to anyone who made an effort to help.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: debug question in netBeans