wood burning stoves 2.0*
The moose likes Websphere and the fly likes change hostname & port Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "change hostname & port" Watch "change hostname & port" New topic
Author

change hostname & port

Bitzu Ma
Greenhorn

Joined: Feb 18, 2010
Posts: 6
Hi all!
I have an enterprise app deployed on a cluster (2 WebSphere 6.1 with a deployment manager). I enter remote desktop on the deployment manager machine and access the app with http://localhost:9081/myapp. I want to be able to access it with http://myhost/myapp.

Please tell me how can I do this. (I would appreciate it if you could tell me the "path" to finding the important pages in adminconsole)

Thanks!

Edit #1 I started by changing the port to 80:
1. created a new port for each of the two servers (Application servers > <server> > Ports): name=NSIWEB_DEFAULT hostname=* port=80
2. added the new port to the transport chain of each of the servers (Application servers > <server> > Ports > Transport Chain > WCInboundDefault > TCP inbound channel (TCP_2))
3. added a new host alias for the default_host my web module uses: hostname=* port=80
4. restarted cluster and updated plug-in configuration

When the application is restarted I get the following errors in the log:
...
[2/25/10 16:28:47:750 CET] 0000002a VirtualHost I SRVE0250I: Web Module NSIWeb has been bound to default_host[*:9081,*:9080,*:9443,*:5060,*:5061,*:443,ensv19rv.enad02.eni.pri:9080,ensv19rv.enad02.eni.pri:9443,ensv19rv.enad02.eni.pri:5060,ensv19rv.enad02.eni.pri:5061,ensv19rv.enad02.eni.pri:443,*:80].
...
[2/25/10 16:28:47:797 CET] 0000000a TCPChannel I TCPC0001I: TCP Channel TCP_1 is listening on host * (IPv4) port 9062.
[2/25/10 16:28:47:797 CET] 0000000a WSChannelFram A CHFW0019I: The Transport Channel Service has started chain WCInboundAdmin.
[2/25/10 16:28:47:812 CET] 0000000a TCPPort E TCPC0003E: TCP Channel TCP_2 initialization failed. The socket bind failed for host * and port 80. The port may already be in use.

...
[2/25/10 16:28:47:843 CET] 0000000a WSChannelFram A CHFW0019I: The Transport Channel Service has started chain WCInboundDefaultSecure.
[2/25/10 16:28:47:843 CET] 0000000a WSChannelFram A CHFW0019I: The Transport Channel Service has started chain SOAPAcceptorChain1.
[2/25/10 16:28:47:843 CET] 0000000a TCPPort E TCPC0003E: TCP Channel TCP_2 initialization failed. The socket bind failed for host * and port 80. The port may already be in use.
[2/25/10 16:28:47:843 CET] 0000000a WSChannelFram E CHFW0034W: The Transport Channel Service detected transport chain SOAPAcceptorChain2 failed. The service will retry to start chain SOAPAcceptorChain2 every 5000 milliseconds for up to 60 attempts.

...
[2/25/10 16:33:48:148 CET] 00000012 ServiceLogger I com.ibm.ws.ffdc.IncidentStreamImpl initialize FFDC0009I: FFDC opened incident stream file D:\Program Files\IBM\WebSphere\AppServer\profiles\AppSrv01\logs\ffdc\ENSV19RY_e4e0e4e_10.02.25_16.33.48_0.txt
[2/25/10 16:33:48:164 CET] 00000012 ChainStartAla E CHFW0033E: The Transport Channel Service failed to start transport chain WCInboundDefault after 60 attempts to start it.


The incident stream file contains this exception: com.ibm.wsspi.channel.framework.exception.RetryableChannelException: Address already in use: bind.

Paul Clapham
Bartender

Joined: Oct 14, 2005
Posts: 18709
    
    8

That isn't part of the Websphere configuration. If you want to address a particular machine under the name "myhost" then you have to change your network's DNS configuration to give that name to that machine.
Bitzu Ma
Greenhorn

Joined: Feb 18, 2010
Posts: 6
Paul Clapham wrote:That isn't part of the Websphere configuration. If you want to address a particular machine under the name "myhost" then you have to change your network's DNS configuration to give that name to that machine.

Thanks Paul, you are right. The machine is reachable under "myhost" name now but I still have to change the port. Check the edit I made in the original post. Any thoughts on that?
java temp
Greenhorn

Joined: Jul 03, 2013
Posts: 1
Shut down Rad.
Open task manager.
Under Processes tab.
Delete any running versions of eclipse.exe and java.exe & javaw.exe.
Open RAD, restart server.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: change hostname & port