• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Running jFlex

 
Hunter McMillen
Ranch Hand
Posts: 492
Firefox Browser Linux VI Editor
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Does anyone have any experience running the jFlex??

I have downloaded and installed jFlex, and following the directions changed both my JAVA_HOME path and JFLEX_HOME path to where both files exist. When I try to run jFlex from the command line I receive this error:


'jflex' is not recognized as an internal or external command,
operable program or batch file.

any help would be great,
Hunter
 
Campbell Ritchie
Sheriff
Pie
Posts: 47228
52
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are you supposed to add the jFlex installation directory to your PATH? I don't remember doing that ever; is it the same JFlex as I have used?
 
Hunter McMillen
Ranch Hand
Posts: 492
Firefox Browser Linux VI Editor
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This is the exact instruction:

Edit the file bin\jflex.bat (in the example it's C:\JFlex\bin\jflex.bat) such that
JAVA_HOME contains the directory where your Java JDK is installed (for instance C:\java) and
JFLEX_HOME the directory that contains JFlex (in the example: C:\JFlex)

I set JAVA_HOME to where my jdk is: C:\Program Files\Java
and JFLEX_HOME to where the jFlex is: C:\Documents and Settings\Hunter\Desktop\jflex-1.4.3\lib

Campbell do you see any mistakes??


Thanks
Hunter
 
Campbell Ritchie
Sheriff
Pie
Posts: 47228
52
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That appears to be the same JFlex I have used (but I used it only on Linux), but surely JAVA_HOME ends with \jdk1_6_0_18 or similar, despite the example they give here?
 
Ulf Dittmer
Rancher
Pie
Posts: 42966
73
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
JFLEX_HOME : C:\Documents and Settings\Hunter\Desktop\jflex-1.4.3\lib

Just a hunch, but that should probably be C:\Documents and Settings\Hunter\Desktop\jflex-1.4.3 (without the "\lib")
 
Don't get me started about those stupid light bulbs.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic