• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

set property error?

 
Samanthi perera
Ranch Hand
Posts: 510
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
this is my struts.xml


this is my java class


this is HelloWorld.jsp


here is output


where is the error in set property?

 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Indent your XML and JSP. Do you understand how difficult it is to read unformatted code and configuration?
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Post what the actual error is.
 
Samanthi perera
Ranch Hand
Posts: 510
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator


but project is working?
or it is still working on last time values?
 
Samanthi perera
Ranch Hand
Posts: 510
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
here is my new HelloWorld.jsp


here is my output


it lost one row?
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Still don't have commons-fileupload and/or commons-io.
 
Mark E Hansen
Ranch Hand
Posts: 650
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can't you just list the jar files in the text of your message? I can't see those screen shots - they are just too small.
Here, let me show you how it would be done:
  • Here is item one
  • Here is item two
  • Here is item three

  •  
    David Newton
    Author
    Rancher
    Posts: 12617
    IntelliJ IDE Ruby
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    @Samanthi: I've asked you *repeatedly* not to post screenshots for things where a screenshot is sub-optimal. I've deleted the message with the attachment.

    Double-check your deployment, because the error message *clearly* indicates the class was not found, which means the library isn't being deployed.
     
    Samanthi perera
    Ranch Hand
    Posts: 510
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    commons-fileupload
    commons-io
    commons-logging-api-1.1
    freemarker
    ognl-2.6.11
    struts2-core-2.0.6
    struts2tutorial
    xwork-2.0.2
     
    David Newton
    Author
    Rancher
    Posts: 12617
    IntelliJ IDE Ruby
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Do you know how to get a directory listing?
     
    Samanthi perera
    Ranch Hand
    Posts: 510
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    hm, i don't know?
     
    David Newton
    Author
    Rancher
    Posts: 12617
    IntelliJ IDE Ruby
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    I'd recommend getting some familiarity with whatever operating system you're using. Being able to get a directory listing is about the most basic task any developer should be able to do.

    http://linuxdevcenter.com/lpt/a/1329
     
    Samanthi perera
    Ranch Hand
    Posts: 510
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    i am using Windows Xp 2.
    I found this for windows

    dir /a /-p /o:gen
     
    Mark E Hansen
    Ranch Hand
    Posts: 650
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Samanthi perera wrote:i am using Windows Xp 2.
    I found this for windows

    dir /a /-p /o:gen


    How about dir /B?
    For example, here's a listing of the WEB-INF/lib directory from one of my Struts 2 web application:

    Please note how my listing includes the complete file name for each file, which includes the version information.
     
    • Post Reply
    • Bookmark Topic Watch Topic
    • New Topic