aspose file tools*
The moose likes JBoss/WildFly and the fly likes Issues with JBoss while starting the application server Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Issues with JBoss while starting the application server" Watch "Issues with JBoss while starting the application server" New topic
Author

Issues with JBoss while starting the application server

Irfan Salar
Greenhorn

Joined: Mar 01, 2010
Posts: 5
Hi..I am using jboss-5.0.0.CR2 with JDK 1.6. After I see the following warning while starting the JBoss server and the applications deployed do not work though I can see the message JBOSS started successfully..

22:29:56,205 WARN [HackClassloaderMetaDataDeployer] FIXME Using loader repository config: jboss.console:sar=console-mgr.sar for vfsfile:/D:/jboss-5.0.0.CR2/server/default/deploy/management/console-mgr.sar/ use classloading metadata not loader repository config

I suspect the above warning as the culprit for the issue. I tried uninstall/re-install too and that did not help.
I am not able to see http://localhost:8080 page after starting the server. I am new to JBoss and using it only since 2 weeks.
I was able deploy applications and able to view JBoss home page for the first week without any issue but problem started recently.

There were few other warnings but only after I saw the above warning the problem started. Please help to fix as I am running out of ideas on this problem.. Thanks..Expecting someone to bail me out of this issue...
Mark E Hansen
Ranch Hand

Joined: Apr 01, 2009
Posts: 650
Well, did you try a Google search?

http://www.lmgtfy.com/?q=%2BJBoss+%2BHackClassloaderMetaDataDeployer

Have a look at the very first result.

It sounds like it was a problem in that release. You should try using a standard release, rather than a candidate release. I believe the current release is 5.1.0.GA. Download that and see if it works.
Irfan Salar
Greenhorn

Joined: Mar 01, 2010
Posts: 5
Thanks Mark for your suggestion. I installed JBoss 5.1.0GA and it worked. I am able deploy applications normally.
But when I try to start JBoss 5.1.0GA from eclipse (Version: 3.4.2 ) it fails with the following error messages.

01:06:51,583 ERROR [AbstractKernelController] Error installing to Instantiated: name=AttachmentStore state=Described
java.lang.IllegalArgumentException: Wrong arguments. new for target java.lang.reflect.Constructor expected=[java.net.URI] actual=[java.io.File]
at org.jboss.reflect.plugins.introspection.ReflectionUtils.handleErrors(ReflectionUtils.java:395)
at org.jboss.reflect.plugins.introspection.ReflectionUtils.newInstance(ReflectionUtils.java:153)
at org.jboss.reflect.plugins.introspection.ReflectConstructorInfoImpl.newInstance(ReflectConstructorInfoImpl.java:106)
at org.jboss.joinpoint.plugins.BasicConstructorJoinPoint.dispatch(BasicConstructorJoinPoint.java:80)
at org.jboss.aop.microcontainer.integration.AOPConstructorJoinpoint.createTarget(AOPConstructorJoinpoint.java:282)
at org.jboss.aop.microcontainer.integration.AOPConstructorJoinpoint.dispatch(AOPConstructorJoinpoint.java:103)
at org.jboss.kernel.plugins.dependency.KernelControllerContextAction$JoinpointDispatchWrapper.execute(KernelControllerContextAction.java:241)
at org.jboss.kernel.plugins.dependency.ExecutionWrapper.execute(ExecutionWrapper.java:47)
at org.jboss.kernel.plugins.dependency.KernelControllerContextAction.dispatchExecutionWrapper(KernelControllerContextAction.java:109)
at org.jboss.kernel.plugins.dependency.KernelControllerContextAction.dispatchJoinPoint(KernelControllerContextAction.java:70)
at org.jboss.kernel.plugins.dependency.InstantiateAction.installActionInternal(InstantiateAction.java:66)
at org.jboss.kernel.plugins.dependency.InstallsAwareAction.installAction(InstallsAwareAction.java:54)
at org.jboss.kernel.plugins.dependency.InstallsAwareAction.installAction(InstallsAwareAction.java:42)
at org.jboss.dependency.plugins.action.SimpleControllerContextAction.simpleInstallAction(SimpleControllerContextAction.java:62)
at org.jboss.dependency.plugins.action.AccessControllerContextAction.install(AccessControllerContextAction.java:71)
at org.jboss.dependency.plugins.AbstractControllerContextActions.install(AbstractControllerContextActions.java:51)
at org.jboss.dependency.plugins.AbstractControllerContext.install(AbstractControllerContext.java:348)
at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:1631)
at org.jboss.dependency.plugins.AbstractController.incrementState(AbstractController.java:934)
at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:1082)
at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:984)
at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:774)
at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:540)
at org.jboss.kernel.plugins.deployment.AbstractKernelDeployer.deployBean(AbstractKernelDeployer.java:319)
at org.jboss.kernel.plugins.deployment.AbstractKernelDeployer.deployBeans(AbstractKernelDeployer.java:297)
at org.jboss.kernel.plugins.deployment.AbstractKernelDeployer.deploy(AbstractKernelDeployer.java:130)
at org.jboss.kernel.plugins.deployment.BasicKernelDeployer.deploy(BasicKernelDeployer.java:76)
at org.jboss.bootstrap.microcontainer.TempBasicXMLDeployer.deploy(TempBasicXMLDeployer.java:91)
at org.jboss.bootstrap.microcontainer.TempBasicXMLDeployer.deploy(TempBasicXMLDeployer.java:161)
at org.jboss.bootstrap.microcontainer.ServerImpl.doStart(ServerImpl.java:138)
at org.jboss.bootstrap.AbstractServerImpl.start(AbstractServerImpl.java:450)
at org.jboss.Main.boot(Main.java:221)
at org.jboss.Main$1.run(Main.java:556)
at java.lang.Thread.run(Unknown Source)
Failed to boot JBoss:
java.lang.IllegalStateException: Incompletely deployed:

DEPLOYMENTS IN ERROR:
Deployment "AttachmentStore" is in error due to: java.lang.IllegalArgumentException: Wrong arguments. new for target java.lang.reflect.Constructor expected=[java.net.URI] actual=[java.io.File]

DEPLOYMENTS MISSING DEPENDENCIES:
Deployment "ProfileServiceBootstrap" is missing the following dependencies:
Dependency "ProfileService" (should be in state "Installed", but is actually in state "Instantiated")
Dependency "jboss.kernel:service=Kernel" (should be in state "Installed", but is actually in state "**ERROR**")
Deployment "ProfileServiceDeployer" is missing the following dependencies:
Dependency "AttachmentStore" (should be in state "Installed", but is actually in state "**ERROR**")
Deployment "ProfileService" is missing the following dependencies:
Dependency "jboss.kernel:service=KernelController" (should be in state "Installed", but is actually in state "**ERROR**")
Dependency "ProfileServiceDeployer" (should be in state "Installed", but is actually in state "Instantiated")
Deployment "ProfileServicePersistenceDeployer" is missing the following dependencies:
Dependency "AttachmentStore" (should be in state "Installed", but is actually in state "**ERROR**")

at org.jboss.kernel.plugins.deployment.AbstractKernelDeployer.internalValidate(AbstractKernelDeployer.java:278)
at org.jboss.kernel.plugins.deployment.AbstractKernelDeployer.validate(AbstractKernelDeployer.java:174)
at org.jboss.bootstrap.microcontainer.ServerImpl.doStart(ServerImpl.java:142)
at org.jboss.bootstrap.AbstractServerImpl.start(AbstractServerImpl.java:450)
at org.jboss.Main.boot(Main.java:221)
at org.jboss.Main$1.run(Main.java:556)
at java.lang.Thread.run(Unknown Source)
01:06:52,381 INFO [ServerImpl] Runtime shutdown hook called, forceHalt: true
01:06:52,381 INFO [ServerImpl] Shutdown complete
Shutdown complete
Halting VM

However, I am able to start JBoss 5.1.0GA over command line and able to view http://localhost:8080 and also was able to deploy basic applications. When I switched to eclipse the JBoss simply do not start..Any ideas??? Earlier I was able to start JBoss 5.0.0GA with both command line & over eclipse without any issue.
Mark E Hansen
Ranch Hand

Joined: Apr 01, 2009
Posts: 650
Are you sure you updated the targeted runtimes in your Project Properties? Perhaps it's still pointing to the old version of JBoss?

I'm not sure you can just edit the one that's there, so you may have to remove it and create a new one that points to your new JBoss installation.

Irfan Salar
Greenhorn

Joined: Mar 01, 2010
Posts: 5
Yes, Mark..Project properties is pointing to the latest JBoss 5.1.0GA but starting JBoss server always fails in eclipse. Please refer attached screenshot..


[Thumbnail for Screen.JPG]

Mark E Hansen
Ranch Hand

Joined: Apr 01, 2009
Posts: 650
I wonder if Eclipse is trying to run JBoss using its version of the JDK, while JBoss is expecting another? For example, that version of JBoss comes in two flavors: One compiled with JDK 1.6, which generally speaking needs to run using JDK 1.6, and one compiled with JDK 1.5 which generally speaking can run in either environment.

Otherwise, I'm out of ideas. You may want to take the errors you're seeing in the server log file to the JBoss forum and see if they have any ideas why it would run under Eclipse.

Sorry.
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5842
    
    7

Did you install JBoss Tools into Eclipse? If not, try doing that and creating a Server using the JBoss Community list of servers.


JBoss In Action
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Issues with JBoss while starting the application server