File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes IDEs, Version Control and other tools and the fly likes install VE into Eclipse Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "install VE into Eclipse" Watch "install VE into Eclipse" New topic
Author

install VE into Eclipse

mahdi farzami
Ranch Hand

Joined: Nov 21, 2009
Posts: 32
Hi , i want to install VE into eclipse and i do it according following link : eclipse wiki but there is a probleam :
The operation cannot be completed. See the details.

and details is :
Cannot complete the install because one or more required items could not be found.
Software being installed: Visual Editor 1.4.0.v20090826-1446-777N-CcNBC0BwNk5HZZk (org.eclipse.ve.feature.group 1.4.0.v20090826-1446-777N-CcNBC0BwNk5HZZk)
Missing requirement: Visual Editor Java Core 1.4.0.v20090826-1446 (org.eclipse.ve.java.core 1.4.0.v20090826-1446) requires 'bundle org.eclipse.emf.codegen [2.3.0,3.0.0)' but it could not be found
Cannot satisfy dependency:
From: Visual Editor 1.4.0.v20090826-1446-777N-CcNBC0BwNk5HZZk (org.eclipse.ve.feature.group 1.4.0.v20090826-1446-777N-CcNBC0BwNk5HZZk)
To: org.eclipse.ve.java.core [1.4.0.v20090826-1446

can any body help me to install ve ???
thanks
David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

What version of Eclipse are you trying to install into? Is it the EE version? Have you met the EMF requirements?
mahdi farzami
Ranch Hand

Joined: Nov 21, 2009
Posts: 32
What version of Eclipse are you trying to install into? Is it the EE version? Have you met the EMF requirements?

Version: 3.5.1 , it`s standard version i install it from fedora repositorys , what is EMF ??? is ve for EE version ??? i want to insattal it for visual disign (drag and drop ) like netbeans for standard version of java
David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

You need to make sure that your Eclipse installation meets the requirements on the wiki page, and isn't affected by the bug.
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5836
    
    7

it`s standard version i install it from fedora repositorys

There is your problem. Don't install the distro version. Instead, uninstall that version and download and install the Eclispe IDE for Java Developers (or for Java EE developers) from the Eclipse download site. To install, all you have to do is unpack the downloaded file - I put mine at /opt/eclipse.


JBoss In Action
David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

Peter Johnson wrote:(or for Java EE developers)

Except that the VE wiki says *not* to use the EE version due to an EMF dependency mismatch.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: install VE into Eclipse