Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Agile forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

No 1st page but just the "Directory Listing for"...index.html

 
Mimi Tam
Ranch Hand
Posts: 121
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Any help on this would be greatly appreciated. I tried everything that was suggested to me so far but to no avail

I want to see the Welcome Page (index.jsp) when running this project Dynamic Web Project "Original" on Tomcat 6.0.18 from within Eclipse . All I got was a page with the "Directory Listing for"...index.html and the Apache Tomcat 6.0.18 from this link: http://localhost/Original.

My project directories: ../Original/WebContent/WEB-INF/jsp/index.jsp, ../Original/WebContent/WEB-INF/web.xml, (also TestApp-servlet.xml).
I tried all combination and with and without port# on the URL. Nothing works.

Here's my web.xml:

Here's my index.jsp:

Here's my TestApp-servlet.xml:


Any other files that I need to display here for clues?

Please kindly HELP! I shall greatly appreciate it.

 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You list the welcome file as /welcome.jsp, but you indicate no file actually at that location--rather one in WEB-INF (which can't be used as a welcome file, as far as I know, since JSPs under WEB-INF can't be served directly).
 
Mimi Tam
Ranch Hand
Posts: 121
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you so much, David.

I should have run this problem by you earlier and saved quite a bit of agony. My problem had been solved by digging and trying sensible things (as I see it). The solution is exactly what you prescribed.

The move of the index.jsp to under WEB-INF/jsp/ was done by accident when I was trying to solve my ORIGINAL problem. So back to the ORIGINAL problem. That is the one which is really killing me.

My SQL database could not be opened with communication failure. This database and connector worked once last night and now it couldn't be opened again . I tried pinging it on my DOS command line, same error. I pinged "Localhost", same problem I did it standalonne on the Database view, same problem

I am running MySQL 5.1 and Tomcat 6.0.18.

Any ideas will be greatly appreciated.
 
Mimi Tam
Ranch Hand
Posts: 121
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Oh David,

I forgot to give you a crucial piece of info. The communication link failure error is below no matter how you try to connect to it.

Many More Thanks in advance.

ERROR 2003 (HY000) Can't connect to MySQL server on 'localhost' (10061)


2ndmysql.png
[Thumbnail for 2ndmysql.png]
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Please start new threads for new issues.
 
Mimi Tam
Ranch Hand
Posts: 121
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Problem solved!
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic