Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

$Proxy57.get_authToken(Unknown Source)

 
kevin lee sg
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I usually connect to UDDI via non-secure mode with the following code:



Everything turned out fine.

But when I tried connecting to a secure http, I'll get the following errors:



Any idea what went wrong?

Any help is much appreciated!
 
Kevin Eddy
Ranch Hand
Posts: 74
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
kevin lee sg wrote:Hi all,

I usually connect to UDDI via non-secure mode with the following code:



Everything turned out fine.

But when I tried connecting to a secure http, I'll get the following errors:



Any idea what went wrong?

Any help is much appreciated!


I'm not by any stretch of the imagination an expert on security or certificates. But I had a similar issue about 3 or 4 months ago. Here's a link that I used to solve it.
http://blogs.sun.com/andreas/entry/no_more_unable_to_find

It sounds like you need to install the certificate in your cacerts file. Which is what the above link talks about. It would be nice if someone in here gave a high level run down on what certificates do, why they are needed etc. Of course there may already be something in here posted.
 
kevin lee sg
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

Thanks, but the problem still is there...
 
Kevin Eddy
Ranch Hand
Posts: 74
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
kevin lee sg wrote:Hi,

Thanks, but the problem still is there...


Did you try this:
find your installation of the jdk (Example: C:\Program Files\Java\jdk1.6.0_16\) and browse to jre/lib/security. You'll see a file named cacerts. Rename it to cacerts.original. Now you have a backup in case you screw up something. Now take the jssecacerts file you created and copy it to the jre/lib/security directory and rename it to cacerts.

There's a much better solution I'm sure...that's just a quick and dirty solution. I that doesn't work then it's beyond my knowledge set.
 
kevin lee sg
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks, but I've tried many other alternatives, and this seems to be one of them.

Yesterday, I just tried getting a fresh copy of the cert from the server and adding it to the cacerts. It's still the same error.

And tried to set the -Djavax.net.ssl.trustStore option, and removing it totally also.

It still does not help.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic