File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JDBC and the fly likes Operation requires a scrollable ResultSet, but this ResultSet is FORWARD_ONLY Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Databases » JDBC
Bookmark "Operation requires a scrollable ResultSet, but this ResultSet is FORWARD_ONLY" Watch "Operation requires a scrollable ResultSet, but this ResultSet is FORWARD_ONLY" New topic
Author

Operation requires a scrollable ResultSet, but this ResultSet is FORWARD_ONLY

Mario Cageggi
Greenhorn

Joined: Apr 22, 2009
Posts: 8
Hi guys!

Thanks to be so helpful all the times I need of help.. you literary saved my ass many many times!
Well.. let's go to the matter...
In the production environment we are going to use Tomcat 6.0.24. I installed it properly, but when I test my application, in some part I get this exception, that I do not get in the old production tomcat:

org.postgresql.util.PSQLException: Operation requires a scrollable ResultSet, but this ResultSet is FORWARD_ONLY.
at org.postgresql.jdbc2.AbstractJdbc2ResultSet.checkScrollable(AbstractJdbc2ResultSet.java:207)
at org.postgresql.jdbc2.AbstractJdbc2ResultSet.first(AbstractJdbc2ResultSet.java:292)
at org.apache.tomcat.dbcp.dbcp.DelegatingResultSet.first(DelegatingResultSet.java:326)

As driver for the DB I am using postgresql-8.6.603.jdbc3.jar and pg74.216.jdbc3.jar both placed under the CATALINA_HOME/lib.

Can you tell me what is wrong?Am I missing some other libraries? The fact is that the same code is working in the old production environment and in my local host with tomcat6.0.18..

HEEEEEEEEEEEEEEEEEELP!!!

Cheers!
Mario
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Operation requires a scrollable ResultSet, but this ResultSet is FORWARD_ONLY