This week's book giveaway is in the Jobs Discussion forum.
We're giving away four copies of Soft Skills and have John Sonmez on-line!
See this thread for details.
The moose likes Tomcat and the fly likes after loading the project able to see blank page Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "after loading the project able to see blank page" Watch "after loading the project able to see blank page" New topic
Author

after loading the project able to see blank page

abheeshek reddy
Ranch Hand

Joined: Nov 28, 2008
Posts: 41
Hi,

I deployed a project and after clicking on the project hyper link in tomcat manager i am able to see a blank page.

below are the messages from tomcat console

new session is started 0DC66284BB0091375AB94B6A4B898F89
Mar 14, 2010 12:06:37 PM org.apache.struts.tiles.TilesRequestProcessor initDefinitionsMapping
INFO: Tiles definition factory found for request processor '/jgossip'.
Mar 14, 2010 12:06:37 PM org.apache.struts.util.PropertyMessageResources <init>
INFO: Initializing, config='org.apache.struts.actions.LocalStrings', returnNull=true
Mar 14, 2010 12:06:37 PM org.apache.struts.util.PropertyMessageResources <init>
INFO: Initializing, config='org.apache.struts.taglib.html.LocalStrings', returnNull=true
Mar 14, 2010 12:06:37 PM org.apache.struts.util.PropertyMessageResources <init>
INFO: Initializing, config='org.apache.struts.util.LocalStrings', returnNull=true




below is the tail part of my struts-config file


<!-- ===================================== Controller Configuration -->
<controller
processorClass="org.apache.struts.tiles.TilesRequestProcessor"
contentType="text/html ; charset=ISO-8859-1" locale="true"
nocache="true" maxFileSize="800K" debug="1" />
<!-- ================================ Message Resources Definitions -->
<message-resources
parameter="org.jresearch.gossip.resources.lang.lang" />
<message-resources key="skin_default"
parameter="org.jresearch.gossip.resources.skins.default" />
<!-- ======================================= Plug Ins Configuration -->
<plug-in className="org.jresearch.gossip.plugin.JGossipStartUp" />
<plug-in className="org.apache.struts.tiles.TilesPlugin">
<set-property property="definitions-config"
value="/WEB-INF/tiles-defs-jgossip.xml" />
<set-property property="moduleAware" value="true" />
<set-property property="definitions-parser-validate"
value="true" />
</plug-in>
<plug-in className="org.apache.struts.validator.ValidatorPlugIn">
<set-property property="pathnames"
value="/WEB-INF/validator-rules-jgossip.xml,/WEB-INF/validation-jgossip.xml" />
<set-property property="stopOnFirstError" value="false" />
</plug-in>
</struts-config>




please do help me
Thanks in advance
William Brogden
Author and all-around good cowpoke
Rancher

Joined: Mar 22, 2000
Posts: 12835
    
    5
If this was my problem, the first thing I would do is to see if the blank page is due to an empty reply body - try view source or even better, use the Firefox browser with the Firebug plugin to see what is being returned.

One possibility for a blank page would be failure to flush and close the response stream.

Bill
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: after loading the project able to see blank page