aspose file tools*
The moose likes Beginning Java and the fly likes javadoc @author tags don't appear Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Beginning Java
Bookmark "javadoc @author tags don Watch "javadoc @author tags don New topic
Author

javadoc @author tags don't appear

Ed Connery
Ranch Hand

Joined: Mar 11, 2010
Posts: 70
I've never been able to get the author tags to work in javadoc, and wondered if I was doing something wrong. In my most recent Cattle Drive exercise, the instructor's solution starts with a documentation comment. That one didn't work for me either, and it turns out it doesn't work for Katrina either. Any ideas? I'm appending my exchange with Katrina and the documentation comment in question:

************************

Strange! I have no idea...
I also just tried it and the author tags disappeared. Want to go ask on the forums?

On Wed, Mar 17, 2010 at 5:39 PM, Ed Connery <edconnery@pciglobal.com> wrote:
> Hi Katrina,
>
> I see we have our first javadoc comment here. Out of curiosity I ran
> javadoc on this, and--just as any time I tried it on my own code--the
> author tags just disappear and don't appear anywhere in the html.  Any
> idea why? [I'm using 1.6 here but the documentation of 1.6 seems to
> say these tags should work fine.]
>
>           -- Ed
>
>
>
> Here is the instructor's solution:
>
> /** This class will convert an integer to a verbal number. <p>
>
>    Instructor's solution for JavaRanch Cattle Drive assignment
> Java-4a<p>
>
>    Pass in a number such as 45 and get back a string like
>    "forty-five". <p>
>
>    This solution can handle numbers up to 99. <p>
>
>    @author Paul Wheaton
>    @author Marilyn de Queiroz
> */
> public class Say
> {...}
Christophe Verré
Sheriff

Joined: Nov 24, 2005
Posts: 14688
    
  16

You must use the -author command line option to generate it.


[My Blog]
All roads lead to JavaRanch
Ed Connery
Ranch Hand

Joined: Mar 11, 2010
Posts: 70
Ah, thank you Christophe!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: javadoc @author tags don't appear