File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JBoss/WildFly and the fly likes JBoss + OsX Snow Leopard too slow Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "JBoss + OsX Snow Leopard too slow" Watch "JBoss + OsX Snow Leopard too slow" New topic
Author

JBoss + OsX Snow Leopard too slow

Juan Javaloyes
Greenhorn

Joined: Mar 22, 2010
Posts: 13
Hi friends...

Got a serious problem with my development environment on OsX Snow Leopard. My Laptop is a Macbook Pro Unibody, Core2Duo 2.4, 2Gb DDR3 running Snow Leopard. The environment is Eclipse + Seam + JBoss AS. The problem is that JBoss AS takes forever to deploy. The AS 4.2 is a little lighter, but not for so much. 5.0 and 5.1 are almost impossible to use. Also, every time I restart the server it takes longer, and hot deploy is simply impossible. Another thing: when the AS is up, all the system is ralentized. What may be the problem?. Already tried recompile the AS under my system, but the result was even worse.

All JBoss AS versions are A LOT faster under MS Windows (i'm running XP under bootcamp), so, can't count the hardware as a problem.
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10289
    
168

Juan Javaloyes wrote:Hi friends...

Got a serious problem with my development environment on OsX Snow Leopard. My Laptop is a Macbook Pro Unibody, Core2Duo 2.4, 2Gb DDR3 running Snow Leopard. The environment is Eclipse + Seam + JBoss AS.


Can you keep Eclipse out of equation and see if you see the same issue? Is it the slow boot time (as compared to Windows) or is it slow deploy time of seam based application?

[My Blog] [JavaRanch Journal]
Juan Javaloyes
Greenhorn

Joined: Mar 22, 2010
Posts: 13
console startups:

JBoss 5.1 Without any app running/deployed (let's call it "Cold" xD):
OsX: 0m 48s
Windows: 0m 28s (first time was 48s, then 28s)

JBoss 5.1 with ONE app Seam deployed (same app on both systems):
OsX: 1m 15s
Windows: 1m 15s

eclipse startups:

JBoss 5.1 Without any app running/deployed:
OsX: 0m 49s
Windows: 32s

JBoss 5.1 with ONE app Seam deployed (same app on both systems):
OsX: 1m 33s
Windows: 1m 12s

Must note that the seam app is a big one...

What I notice from those tests is that there may be a problem with the eclipse in OsX. And that startup time (1m33s) may seem good, but after some use of the system, it increases each time I deploy the server (there were times when it took 8 whole minutes to deploy the app!!), and sometimes it slows the entire system... maybe I need some more RAM?

I use Eclipse Galileo on both systems. Cocoa32 on Snow Leopard, because there are no JBoss tools compatible with the 64bit version (64bit cocoa version)
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: JBoss + OsX Snow Leopard too slow