aspose file tools*
The moose likes JSF and the fly likes Eclipse + Tomcat 6.0 + Jsf 1.2 Problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Java » JSF
Bookmark "Eclipse + Tomcat 6.0 + Jsf 1.2 Problem" Watch "Eclipse + Tomcat 6.0 + Jsf 1.2 Problem" New topic
Author

Eclipse + Tomcat 6.0 + Jsf 1.2 Problem

Lucas Piva
Greenhorn

Joined: Mar 11, 2010
Posts: 4
Hello,

I'm developing a web application using Eclipse Galileo IDE, Tomcat v6.0 and Mojarra JSF 1.2. I followed a tutorial suggested here (http://balusc.blogspot.com/2008/01/jsf-tutorial-with-eclipse-and-tomcat.html) and everything worked just fine. Then, I added richfaces support and everything went great. But when I tried to start Tomcat this morning, I got the following error:

java.lang.ClassNotFoundException: com.sun.faces.config.ConfigureListener

Full stack trace:



My classpath includes the following:

Charts and JDBC jars
jfreechart-1.0.13.jar
ibatis-2.3.4.726.jar
jtds-1.2.5.jar

JSF and Richfaces
jcommon-1.0.16.jar
commons-beanutils-1.7.0.jar
commons-collections-3.2.jar
commons-digester-1.8.jar
commons-logging-1.1.1.jar
jhighlight-1.0.jar
richfaces-api-3.3.2.SR1.jar
richfaces-impl-3.3.2.SR1.jar
richfaces-ui-3.3.2.SR1.jar

Besides Tomcat v6.0 and Mojarra JSF1.2 (jsf.api.jar and jsf-impl.jar). I double checked for references to another implementation of jsf but couldn't find any. My web.xml looks like this:



Again, yesterday everything was working fine. I didn't change anything in the project, just rebooted. Any help would be greatly appreciated.

Thanks in advance,
Piva
Tom Fulton
Ranch Hand

Joined: Mar 30, 2006
Posts: 95
The RichFaces documentation (for want of a better word) has, in the past, failed to mention all the required .jars (to be fair, the documentation has improved dramatically in the last year). I looked at my applications and noticed that you hadn't included jstl-1.0.jar, which mine do. That's the only thing obvious, and it may not be the problem, but give that a try.

I use JBoss as my target application server...it's possible that there is something RichFaces needs that exists in my server runtime, but as far as the included .jars, that's the only one you don't seem to have.
Nick Potter
Ranch Hand

Joined: May 07, 2008
Posts: 126
You need el-ri.jar, and, if I remember correctly the mojarra jars too. Also jars for your view technology (jsp, facelets?);
Lucas Piva
Greenhorn

Joined: Mar 11, 2010
Posts: 4
Thanks for the replies. I already included jstl-1.2.jar in Tomcat lib directory. Also, Tomcat seems to come with el-api.jar and jsp-api.jar by default. The mojarra jars (jsf-api.jar and jsf-impl.jar) are already in the classpath.

I was able to ' solve' the problem by starting from scratch and adding the jars one by one incrementally. In the end, the project looks identical to the way it was in the beggining, but now I can deploy and run it. If I restart my computer, I get the same error again though.

Any ideas?
Nick Potter
Ranch Hand

Joined: May 07, 2008
Posts: 126
You need the el-ri.jar you have only the contract in el-api, you also need the implementation.

Also, try to remove this:



 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Eclipse + Tomcat 6.0 + Jsf 1.2 Problem