aspose file tools*
The moose likes Struts and the fly likes Struts Startup/Restart Resource Not Found Problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Struts Startup/Restart Resource Not Found Problem" Watch "Struts Startup/Restart Resource Not Found Problem" New topic
Author

Struts Startup/Restart Resource Not Found Problem

Ethan Schreiber
Greenhorn

Joined: Aug 16, 2004
Posts: 1
I am having a strange problem with struts and Tomcat. I am using Struts 1.1 and I have tried both Tomcat 5.0.27 and 4.1.30.

Here is the problem:

When I deploy my war file and start Tomcat, the server starts up fine. When I try to access any struts action, I get "The requested resource (/xxx.do) is not available."

Here is the strange part. If I stop and start Tomcat once, I can then access any action just fine with no resource not available errors.. This happens every time I deploy the app. Anyone know what is going on?

Thank you for your time,

Ethan Schreiber
Marc Peabody
pie sneak
Sheriff

Joined: Feb 05, 2003
Posts: 4727

Strange.

Is the .do set up as your welcome file in web.xml??? If so, you can't do that.

It might also be worth it to check web.xml for ActionServlet's load-on-startup value.


A good workman is known by his tools.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Struts Startup/Restart Resource Not Found Problem
 
Similar Threads
Struts Error
DataSource Error
App fine in WebLogic, not in Tomcat
struts problem
Servlet action is not available