aspose file tools*
The moose likes Linux / UNIX and the fly likes problem  installing java Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » Linux / UNIX
Bookmark "problem  installing java" Watch "problem  installing java" New topic
Author

problem installing java

Yewint Ko
Ranch Hand

Joined: Aug 02, 2009
Posts: 90
Hi geeks.
I have ubuntu 8.4 installed on my machine and a java installer "jdk-6u2-ea-bin-b02-linux-i586-12_apr_2007-rpm.bin"

I try install it
# ./ jdk.....bin

It was not successful and I got some rpm files . How do i continue? please



Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 16250
    
  21

You downloaded the wrong file. RPMs are used by Fedora, Red Hat, CentOS, and SuSe (I think). Ubuntu is Debian-based, and they use ".deb" installer files.

However there's no deb-based installer for the JDK, so just use the generic install file, not the RPM one.

If my memory hasn't fuzzed out too much, there's an "alien" package installer designed to help install RPM files into Ubuntu, but I don't recommend it for this purpose. The generic install is the cleaner way to go.


Customer surveys are for companies who didn't pay proper attention to begin with.
Ben Souther
Sheriff

Joined: Dec 11, 2004
Posts: 13410

Maybe you could tell us a little more about what happened when you tried to run the .bin installer.
"It wasn't successful" doesn't really give us much to work with.

After downloading it, did you change the permissions to allow it to execute?
What directory was it in?
Did you try to install it as root or as a regular user?
What error messages did you see when you tried to run it.

Java API J2EE API Servlet Spec JSP Spec How to ask a question... Simple Servlet Examples jsonf
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 16250
    
  21

It's OK, Ben. The "produced rpm files" was the giveaway.
Yewint Ko
Ranch Hand

Joined: Aug 02, 2009
Posts: 90
yes ,I am working in /opt/ as a root and I changed the permission

# chmod +x <filename>.bin

and then i installed

# ./<filename>.bin

then I am asked to accept the license terms and I type "yes" .So far so good . It starts extracting , unpacking and checksumminig. After a long list of prompting , I got the .rpm file.
Of course .rpm is not usually used extension in Ubuntu. I installed alien package manager to convert it to .deb

# apt-get update
# apt-get install alien

then I try to change .rpm file to .deb

# alien <filename>.rpm

It took along time , but after all , I found the new folder with the same name with rpm file. Actually It should be changed to .deb format. right?
That directory contains many sub directories and finally I found the bin directory in which all java command exists. (I can mension the dir structure if needed).
But when I run the java command or javac command , I got error " cannot initialized VM ...... " . I think , that might be coz of unsuccessful installation.Really weired things .
That is all I got. I google many times and go to many places over the net, but I dont find the solution yet.

Thanks ... ( reallly apologuise for late reply)
Stefan Wagner
Ranch Hand

Joined: Jun 02, 2003
Posts: 1923

why don't you use

apt-cache search sun-java gives me, beneath others (doc, demo, jre, source, ...)
sun-java6-jdk - Sun Java(TM) Development Kit (JDK) 6


http://home.arcor.de/hirnstrom/bewerbung
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: problem installing java