aspose file tools*
The moose likes Struts and the fly likes Action form: data getting lost between form submit and setters on ActionForm Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Action form: data getting lost between form submit and setters on ActionForm" Watch "Action form: data getting lost between form submit and setters on ActionForm" New topic
Author

Action form: data getting lost between form submit and setters on ActionForm

CupraMan
Greenhorn

Joined: Aug 25, 2004
Posts: 2
Hi

I'm out of options on this. Looking for a flash of inspiration from someone. Got an xsl page data posts from the page on submit (I have verified this by changing the form method="get") but a debug in the ActionForm setter methods, shows the setters are getting fired, but nulls are being passed in ...

Any ideas please?
Marc Peabody
pie sneak
Sheriff

Joined: Feb 05, 2003
Posts: 4727

I would double-check that.
If anything, it should set with "" empty String, not null.


A good workman is known by his tools.
CupraMan
Greenhorn

Joined: Aug 25, 2004
Posts: 2
D'oh!

How many hours had I been staring at this and pullig my hair out

Closed checking revealed some fields (that I'm not yet bothered about and so hadn't entered any data into) coming through as ""!

Put data into the page and resubmitted - bingo, data! Then I carefully cross-checked my name= and value= attributes on the other inputs and realised they were subtely misspelt! Aaaagh! :roll:

Thanks Marc
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Action form: data getting lost between form submit and setters on ActionForm