This week's book giveaways are in the Refactoring and Agile forums.
We're giving away four copies each of Re-engineering Legacy Software and Docker in Action and have the authors on-line!
See this thread and this one for details.
Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

problem with action input attribute

 
venkatesh loganathan
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
On validation failure my struts application is displaying a blank page

No exceptions or errors are thrown

I have included <html:errors> in the jsp which is used fpr the input attribute.

Any help regarding this

Thanks in advance

Venkatesh Loganathan
 
Marc Peabody
pie sneak
Sheriff
Posts: 4727
Mac Ruby VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
A blank page usually means that the Action is returning a forward that was never defined in the ActionMapping.

For instance,
if the Action has:
return mapping.findForward("success");

but the ActionMapping has this:
<action ....>
<forward name="next" path="/neverGonnaGoHere.do"></forward>
<forward name="back" path="/neverGonnaGoHere.do"></forward>
</action>

If you have further problems, please reply to this thread rather than creating a new one.
 
Marc Peabody
pie sneak
Sheriff
Posts: 4727
Mac Ruby VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Actually, now that I've read an old post of yours I see that you're attempting to use the input attribute on failed validation to send it to a tile.

However, tiles usually have a dot notation like .myTile
I've never tried it without dot notation myself.

Anyway, it wouldn't hurt to test it with a jsp in the input attribute.
 
venkatesh loganathan
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all
My code is working.The problem was with input attrbute for which i made a separate entry in to my struts-config.xml using relative path

Any idea o email validation.Shud we need to ad our own rules n validator-rules.xml

Thanks
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic