Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Axis2- enable security using Rampart

 
Anjali S Sharma
Ranch Hand
Posts: 279
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator


I am following this article to enable security (using Rampart) on my Axis2 webservice.

I have installed Rampart and also engaged it using the admin UI

Now this article instructs to add the following to services.xml

<parameter name="InflowSecurity">
<action>
<items>Timestamp</items>
</action>
</parameter>

<parameter name="OutflowSecurity">
<action>
<items>Timestamp</items>
</action>
</parameter>

At this point the client (soapUI in this case), is not sending any headers while calling the service. So the service should throw a fault.

But in my case, when I call the service using soapUI (and supplying no headers) it does not throw any error.

It seems that Rampart is not getting engaged.

Can you please guide me as to why this could be happening?

thank you
 
shivendra tripathi
Ranch Hand
Posts: 263
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Does your wsdl has some policy element saying that it expect time stamp? Can you post your wsdl?
 
Anjali S Sharma
Ranch Hand
Posts: 279
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
shivendra tripathi wrote:Does your wsdl has some policy element saying that it expect time stamp? Can you post your wsdl?


For headers do I need to update my WSDL as well?

Here is my WSDL

 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic