File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes BEA/Weblogic and the fly likes How to run Weblogic in Linux with more Heap Space Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "How to run Weblogic in Linux with more Heap Space " Watch "How to run Weblogic in Linux with more Heap Space " New topic
Author

How to run Weblogic in Linux with more Heap Space

Ravi Kiran Va
Ranch Hand

Joined: Apr 18, 2009
Posts: 2234

1.Hi ,

I am using Weblogic Server 10 installed in LINUX .
Currently it is using -XMS 256 -XMX 512 .
Please tell me how can i increase the Memory for Weblogic .
Exactly Under what file and where we need to to make changes ??

We are using Clustering with 2 cluster servers and one Admin Server.

Thanks


Save India From Corruption - Anna Hazare.
Ed Ward
Ranch Hand

Joined: Jan 30, 2006
Posts: 147
You need to pass something like this to the start command:

USER_MEM_ARGS="-Xms512m -Xmx1024m -XX:MaxPermSize=128m"

Typically passed in an alias command or in a start shell script found in [YOURDOMAIN]/bin depending on how you have setup your startup sequences.

Google returns quite a bit around this.

Good luck.
Ravi Kiran Va
Ranch Hand

Joined: Apr 18, 2009
Posts: 2234

Thanks for your response .

I am using Admin and two clustered servers . do i need to set this under startWebLogic.sh (Admin server ) or for Clustered server (startManagedWebLogic.sh)

Please reply .
Ed Ward
Ranch Hand

Joined: Jan 30, 2006
Posts: 147
It's set by servername and you specify the amount of memory each server starts with on the command line for that server. I have Admin and 4 managed servers each starting with a different amount of memory. Take a read through those start scripts and you should get the general idea. I believe everyhing defaults to 256Kb and somewhere in there is a check to see if the server is Admin and whether USER_MEM_ARGS has been set.

Misha Ver
Ranch Hand

Joined: Mar 03, 2008
Posts: 470
Ed Ward wrote:You need to pass something like this to the start command:
USER_MEM_ARGS="-Xms512m -Xmx1024m -XX:MaxPermSize=128m"


I'm not sure what JVM Ravi's Weblogic is using, but Oracle JRockit JVM does not use Perm space, so -XX:MaxPermSize=128m is redundant
Joseph Antoine Raja
Ranch Hand

Joined: Feb 01, 2010
Posts: 32
Hi Ravi,

Before you make changes to java settings please cross verify your swap space and memory limits. allocating more heap space will cause to machine to slow down.

1) since you have mentioned that you have 1-admin & 2-man clustered its better to allocate less heap to Admin.

2) if you want to allocate same [256M-1024M] heap to both managed servers you can edit the startManagedServers.sh script and setDomainEnv.sh

3) If you are using different heap size for 2 managed servers . you can better write a shell script for each server which can start a WL process using Weblogic.Server class in which you can specify the memory size.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: How to run Weblogic in Linux with more Heap Space