Win a copy of Think Java: How to Think Like a Computer Scientist this week in the Java in General forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

problem with run.bat(JBoss)

 
swapnil walke
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi!!
m new to JBoss
run.bat doesnt seems to be workin for me...eventually I've set the correct path for JAVA_HOME.
Whenever I double click on the run.bat file...command prompt flashes for a while..n it goes off...
but when I try to run the bat file form the cmd prompt....I get " 'findstr' is not recognized as an internal or external command,
operable program or batch file."
any clues!!!
Thank You in advance...
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
swapnil, welcome to Java Ranch!

See if this discussion helps (note also that in that discussion I posted a link to another discussion on this same topic, make sure you read that also)
http://www.coderanch.com/t/483085/JBoss/Jboss-failed-run-vista#2169639
 
swapnil walke
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for the reply...
again I've verified my JAVA_HOME path, its correct...I've tested it..in command line..
meanwhile I've tried Jboss v6 this time I 'v edited run.bat....to add 'rem' before the first line
n the output I get is..
I am using jdk1.5

C:\Sun\jboss-6.0.0.M2(2)\jboss-6.0.0.20100216-M2\bin>run

C:\Sun\jboss-6.0.0.M2(2)\jboss-6.0.0.20100216-M2\bin>rem @echo off

C:\Sun\jboss-6.0.0.M2(2)\jboss-6.0.0.20100216-M2\bin>rem -----------------------
--------------------------------------------------

C:\Sun\jboss-6.0.0.M2(2)\jboss-6.0.0.20100216-M2\bin>rem JBoss Bootstrap Script
for Windows

C:\Sun\jboss-6.0.0.M2(2)\jboss-6.0.0.20100216-M2\bin>rem -----------------------
--------------------------------------------------

C:\Sun\jboss-6.0.0.M2(2)\jboss-6.0.0.20100216-M2\bin>rem $Id: run.bat 93458 2009
-09-14 08:44:43Z dimitris@jboss.org $

C:\Sun\jboss-6.0.0.M2(2)\jboss-6.0.0.20100216-M2\bin>if "Windows_NT" == "Windows
_NT" (set "DIRNAME=C:\Sun\jboss-6.0.0.M2(2)\jboss-6.0.0.20100216-M2\bin\" ) els
e (set DIRNAME=.\ )

C:\Sun\jboss-6.0.0.M2(2)\jboss-6.0.0.20100216-M2\bin>rem Read an optional config
uration file.

C:\Sun\jboss-6.0.0.M2(2)\jboss-6.0.0.20100216-M2\bin>if "x" == "x" (set "RUN_CON
F=C:\Sun\jboss-6.0.0.M2(2)\jboss-6.0.0.20100216-M2\bin\run.conf.bat" )
\jboss-6.0.0.20100216-M2\bin\run.conf.bat was unexpected at this time.

C:\Sun\jboss-6.0.0.M2(2)\jboss-6.0.0.20100216-M2\bin> echo Calling C:\Sun\jbos
s-6.0.0.M2(2)\jboss-6.0.0.20100216-M2\bin\run.conf.bat

C:\Sun\jboss-6.0.0.M2(2)\jboss-6.0.0.20100216-M2\bin>
 
Jaikiran Pai
Marshal
Pie
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
again I've verified my JAVA_HOME path, its correct...I've tested it..in command line..


Post the output of

 
swapnil walke
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for the reply..
eventually i've upgraded to jdk6 update...hence output is....

C:\Documents and Settings\Swap>echo %JAVA_HOME%
C:\Program Files\Java\jdk1.6.0_20

I've even changed the port to 9999,as OracleXE was listening to it...on my machine..
 
swapnil walke
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hey guys...Problem was just with the port.....as OracleXE was already listening to port 8080....
as soon as I changed the port no in server/deploy/webapp.sar/server.xml file....it started working....
Peter and Jaikiran........thanks a lot for responding so quickly...it was amazing...
 
Jaikiran Pai
Marshal
Pie
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
swapnil walke wrote:Hey guys...Problem was just with the port.....as OracleXE was already listening to port 8080....
as soon as I changed the port no in server/deploy/webapp.sar/server.xml file....it started working....



Good to know that you got it working. I would however have expected a different kind of error on the console for port related issues.


By the way, you might also want to move the Java installation out of the Program Files folder. It's always recommended not to install Java (or JBoss) in a folder containing a space in its path name. So you could move Java installation to C:/Java/jdk1.6.0_20 (and then set JAVA_HOME appropriately).
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic