• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Tomcat not starting up

 
Sreejith Nair
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

Iam using apple (Mac OSX 10.5.8) to build a dynamic web project. Tried to use TOMCAT 5.5.28 with eclipse 3.3.1. After integrating web container: tomcat with eclipse, noticed that container is not started in the desired way, which it supposed to be.But console logs in eclipse shows that web container get started. Pasting below the console log for your kind reference. But when i fired this specified URL "http://localhost:8080/", HTTP-Status 404 error is been thrown, instead of TOMCAT home page.

Console logs:
---------------
Apr 21, 2010 7:18:05 PM org.apache.catalina.core.AprLifecycleListener lifecycleEvent
INFO: The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: .:/Library/Java/Extensions:/System/Library/Java/Extensions:/usr/lib/java
Apr 21, 2010 7:18:05 PM org.apache.coyote.http11.Http11BaseProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Apr 21, 2010 7:18:05 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 481 ms
Apr 21, 2010 7:18:05 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Apr 21, 2010 7:18:05 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.5.28
Apr 21, 2010 7:18:05 PM org.apache.catalina.core.StandardHost start
INFO: XML validation disabled
Apr 21, 2010 7:18:05 PM org.apache.coyote.http11.Http11BaseProtocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Apr 21, 2010 7:18:05 PM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
Apr 21, 2010 7:18:05 PM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/20 config=null
Apr 21, 2010 7:18:05 PM org.apache.catalina.storeconfig.StoreLoader load
INFO: Find registry server-registry.xml at classpath resource
Apr 21, 2010 7:18:05 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 486 ms

Error message Thrown:
-------------------------
HTTP Status 404 - /

type Status report

message /

description The requested resource (/) is not available.
Apache Tomcat/5.5.28

=-=-=-=-=-=-=-=-=-=-=-=-=-=

Do i need to set any environment variable to resolve the error. in Any pointers regarding the source of error would be appreciated.

Thanks in advance,
Sreejith
 
Misha Ver
Ranch Hand
Posts: 470
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Do you have any content under webapps\ROOT ?
 
William Brogden
Author and all-around good cowpoke
Rancher
Posts: 13058
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The HTTP response 404 indicates that the container is actually running so the problem is that there is no resource matching the URL available.

See the javax.servlet.http.HttpServletResponse javadocs for the meaning of response codes.

Bill
 
Sreejith Nair
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks both of you for the quick and prompt response..

Yes ..Already TOMCAT home page(Index.jsp) and associated files were present in webapps/ROOT folder. Some times, I could see newly created jsp page get executed successfully

through eclipse. But while tried to execute the home page(http://localhost:8080/"), same error (resource not available) resulted.

PS: Most of the times, same error get thrown while executing the JSP files. Pasting one of the instance.

------------------------
HTTP Status 404 - Servlet Faces Servlet is not available

type Status report

message Servlet Faces Servlet is not available

description The requested resource (Servlet Faces Servlet is not available) is not available.
------------------------

Thanks,
Sreejith
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic