aspose file tools*
The moose likes IDEs, Version Control and other tools and the fly likes Tomcat 6, Eclipse and 404 errors oh my! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Tomcat 6, Eclipse and 404 errors oh my!" Watch "Tomcat 6, Eclipse and 404 errors oh my!" New topic
Author

Tomcat 6, Eclipse and 404 errors oh my!

Tevis Money
Greenhorn

Joined: Apr 27, 2010
Posts: 2
Ok, here is what I have:

Tomcat 6.0.20 installed at ~/Tomcat/apache-tomcat-6.0.20
Eclipse Galileo, installed from Ubuntu packages (IIRC, it's been a while since it was installed)
sun-java6-jdk installed from Ubuntu packages
Ubuntu 9.10

The tomcat server is configured in Eclipse as follows (all paths are configured as absolute paths on the computer):
Hostname: localhost
Configuration Path: /Servers/Tomcat v6.0 Server at localhost-config
Use the Tomcat installation: T
Server Path: ~/Tomcat/apache-tomcat-6.0.20
Deploy Path: ~/Tomcat/apache-tomcat-6.0.20/webapps
Server Modules Without Publishing: F
Publish Module Contexts to Separate XML Files: F
Enable Security: F

When I start the Tomcat server from Eclipse, everything starts as normal and I can go to localhost:8080 and I get the tomcat welcome page. I can run the example servlets and everything seems hunky dory.

So next I load my Dynamic Web Project from eclipse onto the Tomcat server (right click -> run as -> run on server), select my Tomcat server and hit run. Eclipse deploys the project, loads up a web browser and I get a 404:



Looking at the output from the server in eclipse I notice the following:



I did some googling about and found that this apparently isn't a big deal and also a suggestion to turn Publish Module Contexts to Separate XML Files on. So I did that, and instead of the warning about the property being unmatched, I instead get the following:



And I still get a 404 error, so I switched back to the original config. Now I'm stuck on what to try next, anyone have any thoughts on why I can't get by servlet to run, even though Tomcat itself is running just fine?

As an extra piece of information, if I go to localhost:8080/CompoundManager/JSP/CompoundMain.jsp, it will find and display that page, so it can clearly get to the files in the CompoundManager deployment.
Tevis Money
Greenhorn

Joined: Apr 27, 2010
Posts: 2
The answer to the question apparently is that I needed to include the project name on the url. So instead of:

localhost:8080/CompoundManager/

I needed

localhost:8080/CompoundManager/CompoundManager

It's always the little things that get you in the end
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Tomcat 6, Eclipse and 404 errors oh my!