wood burning stoves 2.0*
The moose likes Struts and the fly likes Migrating Struts application to Java 5 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Migrating Struts application to Java 5" Watch "Migrating Struts application to Java 5" New topic
Author

Migrating Struts application to Java 5

Rohit Dhodapkar
Ranch Hand

Joined: Apr 27, 2006
Posts: 38
Hi Guys,

We are currently using Struts 1.2.4 (struts.jar) and Jdk 1.3.1. The struts.jar was compiled used jdk 1.4. This information I got from manifest.mf file.

We are now planning to move our application to Java 5. But we would like to retain the version of struts we are using.
Can we use the same struts.jar file or is there a struts 1.2.4 jar available for Java 5?

Regards
David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

Java is backwards-compatible (almost always).
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Migrating Struts application to Java 5
 
Similar Threads
Error in deploying struts: Attribute name invalid according to the specified TLD
In 'html:rewrite' attribute 'action' invalid bcos of old struts,jar
Error in Running Struts Example!!
How can we use struts 1.2.4 in WSAD 5.1
html.ELFormTag problem