wood burning stoves 2.0*
The moose likes Web Services and the fly likes Proble While deploying Web Services Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Web Services
Bookmark "Proble While deploying Web Services" Watch "Proble While deploying Web Services" New topic
Author

Proble While deploying Web Services

Raj Shri
Greenhorn

Joined: May 02, 2010
Posts: 28
Hi,

I know how to create the web services. And I have done. By putting the axis folder in webapp folder and deployed the webservices. It's working fine.

Now I wana create totaly seprate web folder not it tomcat folder somer else in derive and also chage the port 8080 to 1010. Tomcat is woring on port 1010. But when I am deploying the web services it's showing me error.

Please any one can help me?

Error is below:

First Way I am doing *************************************
_______________________________________________________________________

E:\VINAY\tomcatserver\testwebapp\vintest\WEB-INF>java org.apache.axis.client.Adm
inClient -lhttp://localhost:1010/hello/services/AdminService deploy.wsdd
log4j:WARN No appenders could be found for logger (org.apache.axis.i18n.ProjectR
esourceBundle).
log4j:WARN Please initialize the log4j system properly.
Processing file deploy.wsdd
Exception: AxisFault
faultCode: {http://xml.apache.org/axis/}HTTP
faultSubcode:
faultString: (404)Not Found
faultActor:
faultNode:
faultDetail:
{}:return code: 404
<html><head><title>Apache Tomcat/6.0.26 - Error report</tit
le><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;ba
ckground-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;
color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Ari
al,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-f
amily:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-famil
y:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:
Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color :
black;}A.name {color : black;}HR {color : #525D76;}--></style> </hea
d><body><h1>HTTP Status 404 - /hello/services/AdminService</h1
><HR size="1" noshade="noshade"><p><b>t
ype</b> Status report</p><p><b>message</b> <u&g
t;/hello/services/AdminService</u></p><p><b>description&
lt;/b> <u>The requested resource (/hello/services/AdminService) is not
available.</u></p><HR size="1" noshade="noshade&qu
ot;><h3>Apache Tomcat/6.0.26</h3></body></html>
{http://xml.apache.org/axis/}HttpErrorCode:404

____________________________________________________________________________________________


Second way I am doing **************************************************
_____________________________________________________________________

E:\VINAY\tomcatserver\testwebapp\vintest\WEB-INF>java org.apache.axis.client.Adm
inClient deploy.wsdd
log4j:WARN No appenders could be found for logger (org.apache.axis.i18n.ProjectR
esourceBundle).
log4j:WARN Please initialize the log4j system properly.
Processing file deploy.wsdd
Exception: AxisFault
faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.userException
faultSubcode:
faultString: java.net.ConnectException: Connection refused: connect
faultActor:
faultNode:
faultDetail:
{http://xml.apache.org/axis/}stackTrace:java.net.ConnectException: Conne
ction refused: connect
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(Unknown Source)
at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
at java.net.PlainSocketImpl.connect(Unknown Source)
at java.net.SocksSocketImpl.connect(Unknown Source)
at java.net.Socket.connect(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.apache.axis.components.net.DefaultSocketFactory.create(DefaultSoc
ketFactory.java:153)
at org.apache.axis.components.net.DefaultSocketFactory.create(DefaultSoc
ketFactory.java:120)
at org.apache.axis.transport.http.HTTPSender.getSocket(HTTPSender.java:1
91)
at org.apache.axis.transport.http.HTTPSender.writeToSocket(HTTPSender.ja
va:404)
at org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:138)

at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrateg
y.java:32)
at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
at org.apache.axis.client.AxisClient.invoke(AxisClient.java:165)
at org.apache.axis.client.Call.invokeEngine(Call.java:2784)
at org.apache.axis.client.Call.invoke(Call.java:2767)
at org.apache.axis.client.Call.invoke(Call.java:1792)
at org.apache.axis.client.AdminClient.process(AdminClient.java:439)
at org.apache.axis.client.AdminClient.process(AdminClient.java:404)
at org.apache.axis.client.AdminClient.process(AdminClient.java:410)
at org.apache.axis.client.AdminClient.process(AdminClient.java:320)
at org.apache.axis.client.AdminClient.main(AdminClient.java:463)

{http://xml.apache.org/axis/}hostname:TSILPDL001


In both I am getting error.


Thanks




cnivas redy
Greenhorn

Joined: Apr 19, 2008
Posts: 17
if you change the port number I guess tomcat runs fine on that port, but if you put your web app some where in the drive and wants to point to that application by using tomcat... I don't understand how tomcat will know that your application is residing at c:\... so and so location.. as per my knowledge tomcat looks for webapplications deployed in <tomcat root>/webapps directory. so I'm guessing because its not in webapps directory you are getting 404 (not found error).
 
Don't get me started about those stupid light bulbs.
 
subject: Proble While deploying Web Services