Meaningless Drivel is fun!*
The moose likes Web Services Certification (SCDJWS/OCEJWSD) and the fly likes ClassNotFoundException: TypeSystemHolder Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCM Java EE 6 Enterprise Architect Exam Guide this week in the OCMJEA forum!
JavaRanch » Java Forums » Certification » Web Services Certification (SCDJWS/OCEJWSD)
Bookmark "ClassNotFoundException: TypeSystemHolder" Watch "ClassNotFoundException: TypeSystemHolder" New topic
Author

ClassNotFoundException: TypeSystemHolder

Sumeet Chakraborty
Ranch Hand

Joined: Feb 05, 2009
Posts: 45
Hi All

I have a simple client program to invoke a web service on Axis2. The following is the code :



The services are succesfullt deployed on Axis2 Server and its ready to be invoked. But wen I run this client program , it gives ne the following Exception :




I am not able to understand the followling part :
Caused by: java.lang.ClassNotFoundException: schemaorg_apache_xmlbeans.system.sEE23823DC08BE88C8EAD145415BC606F.TypeSystemHolder

The build path includes the concerned jar as well : xmlbeans-2.3.0.jar

I am stuck in this. Please help.

Thanks
Sumeet Chakraborty
Ranch Hand

Joined: Feb 05, 2009
Posts: 45
I managed to rectify the above exception by adding the folder containing the clas to the class path.

But after that I am facing the following issue :




I really dont have any clue for this . Please help
Ivan Krizsan
Ranch Hand

Joined: Oct 04, 2006
Posts: 2198
    
    1
Hi!
Take a look at this link which shows some JAR files in which the missing class can be found:
http://www.jarfinder.com/index.php/java/info/org.apache.xmlbeans.SchemaTypeSystem
Perhaps you are missing one of those JARs?
Best wishes!
Sumeet Chakraborty
Ranch Hand

Joined: Feb 05, 2009
Posts: 45
Thanks Ivan. But thats not the problem. I already confirmed the availability of this jar and made sure its not out of reach to my program. But its just not happenng.

I am doubting .. is this any kind of compatibility problem ??

Please help.
Rajesh gonjipalli
Greenhorn

Joined: Feb 06, 2011
Posts: 1
[size=7][/size]Can you please let me know how you solved this problem?
Samuel Jason
Greenhorn

Joined: Jun 26, 2011
Posts: 10
Guys - Do we have a solution to this problem. I am facing similar issues.
A Kiswani
Greenhorn

Joined: Jul 12, 2011
Posts: 1
okkkk , I got the same error too
However, I just fixed it, and connected to share point website for the first time

Basically I did what Sumeet says above... which in my case added the resource folder to the class path...
the resource folder should contain the missing xsb files example "schemaorg_apache_xmlbeans.system..........TypeSystemHolder"

good luck!
Manjunath Patil
Greenhorn

Joined: Dec 03, 2012
Posts: 1
Added this in your pom.xml. error wil go

<!--
this tells maven to copy the openejb-javaagent jar into your target/
directory
-->
<!-- where surefire can see it -->
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-dependency-plugin</artifactId>
<version>2.1</version>
<executions>
<execution>
<id>copy</id>
<phase>process-resources</phase>
<goals>
<goal>copy</goal>
</goals>
<configuration>
<artifactItems>
<artifactItem>
<groupId>org.apache.openejb</groupId>
<artifactId>openejb-javaagent</artifactId>
<version>3.0-beta-2</version>
<outputDirectory>${project.build.directory}</outputDirectory>
</artifactItem>
</artifactItems>
</configuration>
</execution>
</executions>
</plugin>
</plugins>
<resources>
<resource>
<directory>target/generated-sources/axis2/wsdl2code/resources</directory>
</resource>
<resource>
<directory>target/generated-sources/xmlbeans/resources</directory>
</resource>
<resource>
<directory>src/main/resources</directory>
</resource>
</resources>
</build>
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: ClassNotFoundException: TypeSystemHolder