aspose file tools*
The moose likes IDEs, Version Control and other tools and the fly likes Eclipse 3.4.3 Start Problem...ClassNotFoundException:org.eclipse.core.runtime.adaptor.EclipseStarter Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Eclipse 3.4.3 Start Problem...ClassNotFoundException:org.eclipse.core.runtime.adaptor.EclipseStarter" Watch "Eclipse 3.4.3 Start Problem...ClassNotFoundException:org.eclipse.core.runtime.adaptor.EclipseStarter" New topic
Author

Eclipse 3.4.3 Start Problem...ClassNotFoundException:org.eclipse.core.runtime.adaptor.EclipseStarter

Rahul Nair
Ranch Hand

Joined: Dec 01, 2007
Posts: 138
Hello,

When i try to run my eclipse i have got the exception in log file:

!SESSION Fri May 14 12:15:19 IST 2010 ------------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2010-05-14 12:15:19.421
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:546)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)

Can you please tell me what is wrong with my configuration file ?


Thanks,
Rahul
Rahul Nair
Ranch Hand

Joined: Dec 01, 2007
Posts: 138
Hi,

Any hint for "java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter" Exception thrown at Eclipse Start Up ?
Still i have not got any solution for this problem ?

Please help me...!


Thanks,

Rahul
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5772
    
    7

Sounds like your Eclipse installation got corrupted. I suggest reinstalling.

According to my search for the class, it should be in:
eclipse/plugins/org.eclipse.osgi_3.5.0.v20090520.jar
That is the Eclipse 3.5 location, the JAR file name will be different for other versions.


JBoss In Action
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Eclipse 3.4.3 Start Problem...ClassNotFoundException:org.eclipse.core.runtime.adaptor.EclipseStarter
 
Similar Threads
A Quest for all of those who don't use RI for HF EJB
please help in setting db connection in jboss
eclipse rcp problem
How to convert java to jar. jar to batch file in eclipse IDE
Initial SessionFactory creation failed.java.lang.ExceptionInInitializerError