GeeCON Prague 2014*
The moose likes Websphere and the fly likes Websphere server takes long time to startup Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Products » Websphere
Bookmark "Websphere server takes long time to startup " Watch "Websphere server takes long time to startup " New topic
Author

Websphere server takes long time to startup

Satheeshkumar Subramaniam
Greenhorn

Joined: Jul 06, 2009
Posts: 21
Hi,

I use wepsphere in eclipse with RAD. Issue is server takes long time whenever i start.
Help me on this

thanks
Deepak Pant
Ranch Hand

Joined: Feb 13, 2004
Posts: 443
Generally running both RAD and WebSphere Base (embedded) server takes long time. But it also depends upon the CPU and Memory you have on your PC.

In case you are migrating from Eclipse-WebLogic/JBOSS to RAD/WAS environment then it definitely takes a lot of time.

Another thing you can do is turn off certain features in RAD like refreshing deployed apps in WAS everything you compile something.
Luke Zechariah
Ranch Hand

Joined: Sep 27, 2005
Posts: 120
I just moved to RAD 7.0 from WSAD 5.1, and am trying to deploy my application on RAD 7.0, I get a lot of debug messages. How do I turn them off?
My application starts after a long time.

For example:
.....
.....
.....
DEBUG 01 Jun 2010 16:45:56,455 (Digester.java:1035) - Fire body() for FactoryCreateRule[className=null, attributeName=null, creationFactory=org.apache.struts.config.ActionForwardFactory@77447744]
DEBUG 01 Jun 2010 16:45:56,470 (Digester.java:1035) - Fire body() for SetPropertiesRule[]
DEBUG 01 Jun 2010 16:45:56,486 (Digester.java:1035) - Fire body() for SetNextRule[methodName=addForwardConfig, paramType=org.apache.struts.config.ForwardConfig]
DEBUG 01 Jun 2010 16:45:56,486 (Digester.java:1055) - Popping body text ''
DEBUG 01 Jun 2010 16:45:56,501 (Digester.java:1065) - Fire end() for SetNextRule[methodName=addForwardConfig, paramType=org.apache.struts.config.ForwardConfig]
DEBUG 01 Jun 2010 16:45:56,517 (SetNextRule.java:186) - [SetNextRule]{struts-config/action-mappings/action/forward} Call org.apache.struts.action.ActionMapping.addForwardConfig(ForwardConfig[name=loadFailure,path=returnedClaimDetail.page,redirect=false,contextRelative=false,module=null])
DEBUG 01 Jun 2010 16:45:56,517 (MethodUtils.java:522) - Matching name=addForwardConfig on class org.apache.struts.action.ActionMapping
DEBUG 01 Jun 2010 16:45:56,533 (MethodUtils.java:537) - Found straight match: public void org.apache.struts.config.ActionConfig.addForwardConfig(org.apache.struts.config.ForwardConfig)
DEBUG 01 Jun 2010 16:45:56,548 (MethodUtils.java:538) - isPublic:true
DEBUG 01 Jun 2010 16:45:56,548 (Digester.java:1065) - Fire end() for SetPropertiesRule[]
DEBUG 01 Jun 2010 16:45:56,564 (Digester.java:1065) - Fire end() for FactoryCreateRule[className=null, attributeName=null, creationFactory=org.apache.struts.config.ActionForwardFactory@77447744]
DEBUG 01 Jun 2010 16:45:56,580 (FactoryCreateRule.java:424) - [FactoryCreateRule]{struts-config/action-mappings/action/forward} Pop org.apache.struts.action.ActionForward
DEBUG 01 Jun 2010 16:45:56,580 (Digester.java:1132) - ignorableWhitespace(
)
DEBUG 01 Jun 2010 16:45:56,595 (Digester.java:1243) - startElement(,forward,forward)
DEBUG 01 Jun 2010 16:45:56,595 (Digester.java:1250) - Pushing body text ''
DEBUG 01 Jun 2010 16:45:56,611 (Digester.java:1269) - New match='struts-config/action-mappings/action/forward'
DEBUG 01 Jun 2010 16:45:56,626 (Digester.java:1284) - Fire begin() for FactoryCreateRule[className=null, attributeName=null, creationFactory=org.apache.struts.config.ActionForwardFactory@77447744]
DEBUG 01 Jun 2010 16:45:56,626 (FactoryCreateRule.java:392) - [FactoryCreateRule]{struts-config/action-mappings/action/forward} New org.apache.struts.action.ActionForward
DEBUG 01 Jun 2010 16:45:56,673 (Digester.java:1284) - Fire begin() for SetPropertiesRule[]
DEBUG 01 Jun 2010 16:45:56,689 (SetPropertiesRule.java:196) - [SetPropertiesRule]{struts-config/action-mappings/action/forward} Setting property 'name' to 'rfnSuccess'
......
.....so on.

Thanks,
Luke.
Luke Zechariah
Ranch Hand

Joined: Sep 27, 2005
Posts: 120
I changed the "debug" to "info" on the log4j.properties file and it worked. Here is what I did:

Before:


 
GeeCON Prague 2014
 
subject: Websphere server takes long time to startup