File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes JBoss/WildFly and the fly likes Deploying apache-continuum-1.3.6.war on JBoss 6 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Deploying apache-continuum-1.3.6.war on JBoss 6" Watch "Deploying apache-continuum-1.3.6.war on JBoss 6" New topic

Deploying apache-continuum-1.3.6.war on JBoss 6

Celinio Fernandes
Ranch Hand

Joined: Jun 28, 2003
Posts: 549

I am trying to deploy Apache Continuum on JBoss 6.
The war is apache-continuum-1.3.6.war

I get this error :
Deployment "vfszip:/D:/NPCT/Developpement/jboss-" is in error due to the following reason(s): java.lang.LinkageError: loader constraint violation: when resolving overridden method "org.apache.commons.configuration.XMLConfiguration$1.error(Lorg/xml/sax/SAXParseException;)V" the class loader (instance of org/jboss/classloader/spi/base/BaseClassLoader) of the current class, org/apache/commons/configuration/XMLConfiguration$1, and its superclass loader (instance of <bootloader>), have different Class objects for the type org/xml/sax/SAXParseException used in the signature

Does anyone know what's wrong and how to fix it ?
Thanks for helping.

SCJP 1.4, SCWCD 1.4, SCBCD 1.3, SCBCD 5
Visit my blog
Peter Johnson

Joined: May 14, 2008
Posts: 5852

Looks like a JBoss question to me, moving.

JBoss In Action
I agree. Here's the link:
subject: Deploying apache-continuum-1.3.6.war on JBoss 6
It's not a secret anymore!