aspose file tools*
The moose likes Web Services and the fly likes Error: JAXRPC 1.1 method is not supported in WLS 8.1 clients Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Web Services
Bookmark "Error: JAXRPC 1.1 method is not supported in WLS 8.1 clients" Watch "Error: JAXRPC 1.1 method is not supported in WLS 8.1 clients" New topic
Author

Error: JAXRPC 1.1 method is not supported in WLS 8.1 clients

Lavanya Halliwell
Ranch Hand

Joined: Apr 09, 2010
Posts: 57
Here is the senario:

in Jdeveloper, server will be weblogic, I create a new general application.

then I right click the blank app, new, business tier, web services, web service proxy.

after I select the WSDL, I click finish and all the classes are auto generated.

in the main class that I will use to execute the soap request:



Dealer_PortType & Dealer_Service are abstract classes and Interfaces I include in addition to the rest.


what does it mean by "not supported in WLS 8.1 clients"? because I am using Weblogic 10.3.2 and JDeveloper 11g.

NOTE: when I created the web service proxy in the JDev wizard, I selected the JAX-WS option. does this require the JAX-RPC option because I a similar tutorial where they used the JAX-WS option?

Yet another site, one guy was saying to rebuild the proxy class or something? but this was auto generated. (don't know if this point is a rabbit trail but putting it out there)

any pointers would be a appreciated!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Error: JAXRPC 1.1 method is not supported in WLS 8.1 clients