*
The moose likes IDEs, Version Control and other tools and the fly likes Jboss is not starting from eclipse Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Jboss is not starting from eclipse" Watch "Jboss is not starting from eclipse" New topic
Author

Jboss is not starting from eclipse

guddi venu
Greenhorn

Joined: Apr 12, 2010
Posts: 3
Hi all,

I'm using Eclipse galileo and Jboss 5.1.0.GA.

I'm unable to start the jboss server from the eclipse. When i tried to start the jboss from it is showing the below message.

[i][b][b]15:05:58,923 INFO [ServerImpl] JBoss (Microcontainer) [5.1.0.GA (build: SVNTag=JBoss_5_1_0_GA date=200905221053)] Started in 50s:273ms[/i][/b]

but when am trying to deploy the application it is showing it is still in staring state.

Please anybody help in this.

Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5812
    
    7

A search will turn up quite a few discussions on this same topic, many of which have helpful suggestions
http://www.coderanch.com/t/476734/vc/Jboss-server-eclipse-not-starting
http://www.coderanch.com/t/491795/JBoss/Jboss-does-not-finish-startup
http://www.coderanch.com/t/490993/JBoss/Running-JBoss-localy-Eclipse-establish
http://www.coderanch.com/t/90547/JBoss/Change-JBoss-Port-No


JBoss In Action
vins vinsk
Greenhorn

Joined: Jan 13, 2011
Posts: 3
It seems that jboss port in eclipse and what is there in Server.xml (Path : jboss-5.0.0.GA\server\default\deploy\jbossweb.sar ) is not same so just check what is given in server.xml and go to eclipse >Servers and Double click on you created jboss it will open a window in eclipse editor there you need to keep the same "Port" as there in Server.xml file on above location .


it will definitely work .It worked in my case though .....
 
jQuery in Action, 2nd edition
 
subject: Jboss is not starting from eclipse
 
Similar Threads
unable to make connection to jboss under eclipse when using external IP address
Error starting up my jboss
jboss not starting - config issue?
Problem Starting Jboss 5.1.0GA from eclipse 3.4.1
problem in configuring Jboss into eclipse