This week's book giveaway is in the OCMJEA forum.
We're giving away four copies of OCM Java EE 6 Enterprise Architect Exam Guide and have Paul Allen & Joseph Bambara on-line!
See this thread for details.
The moose likes JNLP and Web Start and the fly likes Is It bug in web start? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCM Java EE 6 Enterprise Architect Exam Guide this week in the OCMJEA forum!
JavaRanch » Java Forums » Java » JNLP and Web Start
Bookmark "Is It bug in web start?" Watch "Is It bug in web start?" New topic
Author

Is It bug in web start?

Arshad Ali
Greenhorn

Joined: Nov 29, 2008
Posts: 18
Hi All,

I am totally frustrated with the parsing error

MissingFieldException[ The following required field is missing from the launch file: <jnlp>]
at com.sun.javaws.jnl.XMLFormat.parse(Unknown Source)
at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
at com.sun.javaws.Launcher.updateFinalLaunchDesc(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.launch(Unknown Source)
at com.sun.javaws.Main.launchApp(Unknown Source)
at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
at com.sun.javaws.Main$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)


why it is coming when every thing is fine. When i run the application in localhost it worked, but when i change to IP it is giving parsing error.
I tried saving the file through NetBeans , JEdit and also through notepad coshing Unicode UTF 8. here is my jnlp file.




I do not know why is it happening but it is really pissed me off , Or it is bug in web start that poorly process the xml file.
Any help will be appreciated.

Maneesh Godbole
Saloon Keeper

Joined: Jul 26, 2007
Posts: 10274
    
    8

I think this might be the problem.

There is a white space between the " and the ?


[How to ask questions] [Donate a pint, save a life!] [Onff-turn it on!]
Arshad Ali
Greenhorn

Joined: Nov 29, 2008
Posts: 18
That's works, thanks for reply
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Is It bug in web start?