This week's giveaway is in the EJB and other Java EE Technologies forum.
We're giving away four copies of EJB 3 in Action and have Debu Panda, Reza Rahman, Ryan Cuprak, and Michael Remijan on-line!
See this thread for details.
The moose likes JNLP and Web Start and the fly likes Is It bug in web start? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Java » JNLP and Web Start
Bookmark "Is It bug in web start?" Watch "Is It bug in web start?" New topic
Author

Is It bug in web start?

Arshad Ali
Greenhorn

Joined: Nov 29, 2008
Posts: 18
Hi All,

I am totally frustrated with the parsing error

MissingFieldException[ The following required field is missing from the launch file: <jnlp>]
at com.sun.javaws.jnl.XMLFormat.parse(Unknown Source)
at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
at com.sun.javaws.Launcher.updateFinalLaunchDesc(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.launch(Unknown Source)
at com.sun.javaws.Main.launchApp(Unknown Source)
at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
at com.sun.javaws.Main$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)


why it is coming when every thing is fine. When i run the application in localhost it worked, but when i change to IP it is giving parsing error.
I tried saving the file through NetBeans , JEdit and also through notepad coshing Unicode UTF 8. here is my jnlp file.




I do not know why is it happening but it is really pissed me off , Or it is bug in web start that poorly process the xml file.
Any help will be appreciated.

Maneesh Godbole
Saloon Keeper

Joined: Jul 26, 2007
Posts: 9990
    
    7

I think this might be the problem.

There is a white space between the " and the ?


[How to ask questions] [Donate a pint, save a life!] [Onff-turn it on!]
Arshad Ali
Greenhorn

Joined: Nov 29, 2008
Posts: 18
That's works, thanks for reply
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Is It bug in web start?
 
Similar Threads
dynamic jnlp missing application-desc tag in jsp
Launch Exception encountered in Java Web Start
Could not parse launch file. Error at line 0
missing from the launch file: jnlp
Unable to launch the application